Ionic Pro: How to use Ionic View?

I updated ionic-cli to 3.9
I am dealing with Ionic View for first time.

I created account on

I installed git from to run some commands.

I liked the app using ionic link --pro-id the-id

I got the below output:

C:\Users\PARGE\Documents\ionic\mukta>ionic link --pro-id the-id
[INFO] You have been logged out.
[OK] backend set to "pro" in ..\..\..\.ionic\config.json!

[INFO] You have opted in to Ionic Pro! The CLI is now set up to use Ionic Pro services.
       You can revert back to Ionic Cloud (legacy) services at any time:

       ionic config set -g backend legacy

? App ID ionic-io-app-id already exists in project config. Would you like to link a different app? Yes
Log into your Ionic account
If you don't have one yet, create yours by running: ionic signup

? Email:

? Password: [hidden]
> ionic ssh setup
[ERROR] Command not found: ssh
[WARN] OpenSSH not found on your computer.
[INFO] Looks like you haven't configured your SSH settings yet.

? How would you like to connect to Ionic Pro? Skip for now
[WARN] Skipping for now. You can configure your SSH settings using ionic ssh setup.
√ Looking up app the-id- done!
> ionic config set app_id the-id
[OK] app_id set to "the-id" in .\ionic.config.json!
> ionic git remote
[WARN] Initializing a git repository for your project.

       Before your first git push ionic master, you'll want to commit all the files in your project:

       git commit -a -m "Initial commit"

> git init
> git remote add ionic
[OK] Added remote ionic.
[OK] Project linked with app the-id!

I ran git commit -m “initial commit”


On branch master

Initial commit

Untracked files:

nothing added to commit but untracked files present

ran git push origin master


error: src refspec master does not match any.
error: failed to push some refs to ‘‘’’

what am I doing wrong?

NOTE: I replaced the id with the-id and app name with my-app-name as I don’t know if it’s secure to paste here.

1 Like

I had this yesterday. As I understand it you only can upload when the ssh is set correct.

In my case I have to use the Git Bash


open the git bash
cd to your project root folder
use the command from the documentation


Hi @Jacktoolsnet

Thanks for the hint, but it doesn’t resolve my problems.

So what I did: removed the SSH key in Pro, deleted /c/Users/myname/.ssh (so all local keys gone), got rid of all apps, then created a new app via the Pro dashboard. I used GIT bash for the CLI commands as per Pro dashboard instructions.

But when doing the final git push ionic master, I got the following message:

$ git push ionic master
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Anyone suggestions what I am doing wrong? I am running ionic on a Windows machine.

For now I am sticking to legacy (and somehow ionic uploads does not update all files, btw).



Have you linked your app?



  1. New app in dashboard
  2. npm install -g ionic@latest (bash)
  3. ionic start --pro-id 67613787 (bash - this does the linking)
  4. cd into project dir (bash)
  5. ionic serve ((bash, just as a test to see if the app is ok)
  6. git push ionic master (bash)



Ok I tried your steps and everything works fine on my pc.

Here is my

ionic info

cli packages: (C:\Users\jackt\AppData\Roaming\npm\node_modules)

    @ionic/cli-utils  : 1.9.2
    ionic (Ionic CLI) : 3.9.2

local packages:

    @ionic/app-scripts : 2.1.3
    Ionic Framework    : ionic-angular 3.6.0


    Node : v6.10.2
    npm  : 3.10.10
    OS   : Windows 10

But when I startet with inoc pro two days ago I first tried it with an existing app.

So I have to use

ionic link with the git shell and this creates my ssh keys.

yes, these are also things I did. My ionic info is:

cli packages: (C:\Users\tommertom\AppData\Roaming\npm\node_modules)

    @ionic/cli-utils  : 1.9.2
    ionic (Ionic CLI) : 3.9.2

local packages:

    @ionic/app-scripts : 2.1.3
    Ionic Framework    : ionic-angular 3.6.0


    Node : v6.9.4
    npm  : 3.10.9
    OS   : Windows 7

So will upgrade node and npm. And if that doesn’t work, will try to do ssh with git and github to see if there is something with my openssh installation.

And update here.

Thank you for your help



there seems to be something wrong with the keys.

ssh -vT

gives output that it ran out of authentication methods. I tried to have it use the rsa key using the ~/.ssh/config file, but to no avail.

git push master finds the public key and asks for password, but then fails. Verbose mode on git does not give much either.

Will continue my search, but it is probably not an ionic thing.




just for the record. I got it fixed. It was an issue with the correct location of the .ssh folder and config/known_hosts file.

Managed to figure this out by using a different pc to install all (which also told me it can work), and then copied the keys to the other PC.



1 Like

Are you running on Windows?

I am also having the same problem. I don’t have luxury to use a different PC right now. Any ideas?

Did you contact Ionic support?


I am running windows. Root cause for me is that I am using a corporate laptop for which I dont have admin rights and the home folder wasnt easily found. I did manage to run the portable versions of the keygen tools.

Anyway, it would be helpful if you can elaborate on your specific situation. For instance, can you run the keygen tools, can you find the generated files? Etc


I use git bash. I deleted the config and rsa keys. Ran the ionic ssh setup and it regenerated the keys. The project was link already. Everything work with no errors. But when I issue the git push ionic master, I get the error below:

/c/Users/[UserID]/.ssh/config line 3: garbage at end of line; “[UserID]\.ssh\ionic\743299_rsa”.
fatal: Could not read from remote repository.

Try going to the config file, i.e C:\Users\who ever\.ssh\config and placing quotes around the Identity File path.

IdentityFile "C:\Users\who ever\.ssh\ionic\012345_rsa"

Like so. This should fix the problem, depending on your user name. if there’s a space anywhere in the path, as there is between who and ever, the result is garbage


Thanks @jaydz! This surely fixed it!

Good to hear! It was a frustrating problem for me, so, happy to help someone else.