Ionic Pro: Error in ionic pro build service Cannot find module '@angular/tsc-wrapped/src/tsc'


#1

I get this error after commit to ionic pro:

module.js:487
throw err;
^

Error: Cannot find module '@angular/tsc-wrapped/src/tsc’
at Function.Module._resolveFilename (module.js:485:15)
at Function.Module._load (module.js:437:25)
at Module.require (module.js:513:17)
at require (internal/module.js:11:18)
at Object. (/usr/src/app/node_modules/@ionic/app-scripts/dist/aot/aot-compiler.js:7:13)
at Module._compile (module.js:569:30)
at Object.Module._extensions…js (module.js:580:10)
at Module.load (module.js:503:32)
at tryModuleLoad (module.js:466:12)
at Function.Module._load (module.js:458:3)
npm info lifecycle TCIBestEx@0.0.1~build: Failed to exec build script
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! TCIBestEx@0.0.1 build: ionic-app-scripts build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the TCIBestEx@0.0.1 build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/gitlab-runner/.npm/_logs/2017-10-06T05_09_02_789Z-debug.log
npm run build failed
Make sure your project has a build script in the package.json
Running after script…
$ clean-up
Cleaning up files…


#2

Ionic Pro is a hosted and closed source service, so there is not much we, the community, can help you with, sorry. Check these:

You can - and should - contact support at http://ionicframework.com/support#support


#3

What is your local ionic info output?
Can you build the app locally?


#4

Yes, locally not problem. My ionic info is:

@ionic/cli-utils : 1.12.0
ionic (Ionic CLI) : 3.12.0

global packages:

cordova (Cordova CLI) : 7.0.1

local packages:

@ionic/app-scripts : 2.1.4
Cordova Platforms  : android 6.2.3
Ionic Framework    : ionic-angular 3.6.1

System:

Android SDK Tools : 26.1.1
Node              : v6.11.4
npm               : 5.4.2
OS                : Windows 10

IMPORTANT: I’m using google maps native plugin (verion multiple maps)


#5

Old, upgrade it. Might fix the problem.

But this is just all guesses, you should definitely contact support.


#6

same error after upgrade :frowning:


#7

So have you contact support?


#8

Yes, I’m waiting, thnks


#9

Hi,

I do not know if you have found a solution, just want to share, that I also had the same problem and I solved it by upgrade the ionic to the latest (npm install -g ionic@latest) it wil remove deprecated packages. if necessary you can upgrade @ionic/app-scripts to the latest too.

That’s it, thanks