Ionic Package: Error: Source path does not exist: resources/ios/icon/icon-40.png


#1

Hello guys!!!
I’m getting an error while submiting a build to package service.

  • command:
    ionic package build ios --profile dev

  • Error output on package service:
    iOS project created with cordova-ios@4.3.1
    Error: Source path does not exist: resources/ios/icon/icon-40.png

ionic info

cli packages: (…/node_modules)

@ionic/cli-utils  : 1.8.1
ionic (Ionic CLI) : 3.8.1

global packages:

Cordova CLI : 6.4.0 

local packages:

Cordova Platforms : android 6.1.2
Ionic Framework   : ionic1 1.2.4

System:

Android SDK Tools : 26.0.1
Node              : v6.10.2
npm               : 3.10.10 
OS                : Linux 4.10

How can i generate resources --icon to ios if i’m using package service?
Any fix to that?

thanks! :grinning:


Ionic package build failed?
#2

Does it exist?

Good question, I don’t really know how ionic package handles the resources and icons…
I would try to run it locally again.


#3

Is here an answer available? Im stuck on that issue too.


#4

Which error exactly? What is your ionic info output?


#5

Error: Source path does not exist: resources/ios/icon/icon-40.png

is the error i have when i try to build. I found out that it matters if those files are in the resources/ios folder on my laptop before pushing. I created a blank test object and deleted those files and then the build error was the same. But i have windows. when i do ionic cordova resources, the ios part is not build.

I have searched for two days now in this forum for this stuff.

Ive upgraded ionic before.

cli packages: (C:\Users\kuhnm\AppData\Roaming\npm\node_modules)

@ionic/cli-utils  : 1.13.1
ionic (Ionic CLI) : 3.13.1

global packages:

cordova (Cordova CLI) : 6.5.0

local packages:

Cordova Platforms : android 6.1.2 browser 4.1.0 ios 4.3.1
Ionic Framework   : ionic1 1.3.1

System:

Android SDK Tools : 25.2.3
Node              : v6.10.3
npm               : 3.10.10
OS                : Windows 10

Misc:

backend : pro

#6

That seems to be the same error as here:


#7

maybe this is a problem with ionic version?


#8

Cordova CLI and ios 4.3.1 is quite old - upgrade to recent versions.


#9

i managed to fix it. i downgraded to ionic cli 2.9. and removed the hooks -> prepare -> file

So in my understanding the new cli didnt push the resources or created the resources correctly.

i updated also the cordova cli but that didn’t do anything.


#10

What is your ionic info output now?


#11

Your system information:

ordova CLI: 7.1.0
Ionic CLI Version: 2.2.0
Ionic App Lib Version: 2.2.0
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Windows 10
Node Version: v6.10.3
Xcode version: Not installed


#12

cordova platform list?

My guess is it is more an updated platform, and nothing to do with the CLI.


#13

Installed platforms:
android 6.1.2
browser 4.1.0
ios 4.3.1
Available platforms:
blackberry10 ~3.8.0 (deprecated)
osx ~4.0.1
ubuntu ~4.3.4 (deprecated)
webos ~3.7.0
windows ~5.0.0
www ^3.12.0

I don’t know what the issue is here. Fixed it was by the downgrade of the cli. But i think its got to do with dependencies or stuff.


#14

Now i just inserted a new splash screen, did ionic resources and then again, same mistake with the missing icon. Already updated ios, cordova and ionic cli, also downgraded cli again. Just cant get it to work again.


#15

Post your ionic info and ionic cordova platform list so we can check.


#16

cli packages: (E:\Arbeit\Projekte\Mahlzeit\Programmierung\App\node_modules)

@ionic/cli-utils  : 1.13.1
ionic (Ionic CLI) : 3.13.2

global packages:

cordova (Cordova CLI) : 7.1.0

local packages:

Cordova Platforms : android 6.1.2 browser 4.1.0 ios 4.3.1
Ionic Framework   : ionic1 1.3.1

System:

Android SDK Tools : 25.2.3
Node              : v6.10.3
npm               : 3.10.10
OS                : Windows 10

Misc:

backend : pro

Installed platforms:
android 6.1.2
browser 4.1.0
ios 4.3.1
Available platforms:
blackberry10 ~3.8.0 (deprecated)
osx ~4.0.1
ubuntu ~4.3.4 (deprecated)
webos ~3.7.0
windows ~5.0.0
www ^3.12.0

ios version which is fetched in ionic pro is 4.5.2


#17

I had the same error and I just have downgraded Ionic CLI to 3.12.0 and it works