Ionic Pro: Error Packaging


#1

Hi guys,

I tried to contact the support, but no luck, so I’m posting here. It is amazing how support doesn’t work even when having a paid Ionic Pro subscription. Very disappointed.

The app builds fine locally for Android and builds fine in the cloud. However, when packaging for OS in the cloud I get the following error. I tried removing the android resources from config.xml and also from the resources folder. no luck

$> cordova add platform ios
Using cordova-fetch for cordova-ios@~4.4.0
Adding ios project…
Creating Cordova project for the iOS platform:
Path: platforms/ios
Package: com.test.m
Name: App Name
iOS project created with cordova-ios@4.4.0
Error: Source path does not exist: resources\android\icon\drawable-xhdpi-icon.png
\e[91mFailed to upload ipa to storage please retry your build.\e[0m
Running after script…
$ clean-up
Cleaning up files…
Successful clean up
ERROR: Job failed: exit status 1


#2

Standard text first (mainly for future Google visitors):

Ionic Pro is a hosted and closed source service, so there is not much we, the community, can help you with, sorry. Check these:

You can - and should - contact support at http://ionicframework.com/support#support


#3

What is your ionic info?
Did you regenerate your resources recently?


#4

Found the issue. There was an “icon” element in the config.xml file outside of the resources node. No idea where that came from. It had the wrong style of slashes, hence the error.


#5

I am getting the same issue and just removing this line didn’t seem to work for me. I initially tried your suggestion of replacing forward slashes with backslashes assuming Ionic servers might be using windows based servers.

Apart from that I have also tried removing and values from config.xml and deleting android and ios directories from resources and again running ionic cordova resources but none of that seems to work.

Here is log of ionic info command from my system:

 @ionic/cli-utils  : 1.14.0
    ionic (Ionic CLI) : 3.14.0

global packages:

    cordova (Cordova CLI) : 7.0.1

local packages:

    @ionic/app-scripts : 3.0.0
    Cordova Platforms  : android 6.2.3 ios 4.4.0
    Ionic Framework    : ionic-angular 3.7.1

System:

    ios-deploy : 1.9.2
    Node       : v6.11.1
    npm        : 3.10.10
    OS         : macOS High Sierra
    Xcode      : Xcode 9.0 Build version 9A235

Misc:

    backend : pro

I have already posted this issue on ionic pro forum but considering prior experience I consider this would be be a more suitable place to get comparatively faster response from community.

Thanks


#6

Update: It turns out that I wasn’t pushing ‘resources’ directory to git and had gitignored it. Removing it from .gitignore, pushing new commit and packaging using Ionic pro worked finally.