Ionic Package: Error building in ionic cloud getting error Might need to update your Android SDK


#1
ANDROID_HOME=/opt/android-sdk
JAVA_HOME=/usr/lib/jvm/java-8-oracle
Error: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.
Looked here: /opt/android-sdk/tools/templates/gradle/wrapper

Why am I keep getting this error? I am building in cloud aren’t they supposed to look after the things like Android SDK and Java


Ionic package: error when building in ionic cloud
Ionic Package Service: Android build fails
#2

http://ionicframework.com/support#support
(Scroll down to “Business and Customer Support”)


#3

i update ionic CLI this night . and now i have the same problem. Worked fine before the last update !


#4

+1, ionic package was working this morning but now we’re getting this error.


#5

+1 too have this error


#6

So did you all report it at the URL I posted?


#7

Yes Sujan. I opened a ticket, but they haven’t replied yet.


Android build on apps.ionic.io fails
#8

It works now. You have to update to the last recent cordova android platform (6.2.3)

cordova platform update android@6.2.3 --save

The ionic team gave that feedback to me after I reported the bug.


#9

still doesn’t work for me even after updating cordova :confused:

global packages:

    @ionic/cli-utils : 1.4.0
    Cordova CLI      : 7.0.1 
    Ionic CLI        : 3.4.0

local packages:

    @ionic/app-scripts              : 1.3.7
    @ionic/cli-plugin-cordova       : 1.4.0
    @ionic/cli-plugin-ionic-angular : 1.3.1
    Cordova Platforms               : android 6.2.3
    Ionic Framework                 : ionic-angular 3.3.0

System:

    Node       : v6.10.0
    OS         : Linux 4.4
    Xcode      : not installed
    ios-deploy : not installed
    ios-sim    : not installed
    npm        : 3.10.10 


#10

+1 doesn’t work after updating platform android@6.2.3.


#11

Again, the info is missing if you told the Ionic team about it already.


#12

Does your config.xml contain the following entry?

<engine name="android" spec="~6.2.3" />

After using “–save” this entry was added to my config.xml. This might be important for the cloud package service.


#13

thank you, this worked for me! :+1:


#14

I had to manually add the line <engine name="android" spec="~6.2.3" /> into the config.xml file. (for some reason using “–save” did not automatically add the entry for me… Not sure why it didn’t though… but after adding that line, the build worked! Thanks @echle!!!


#15

Hey,
Does anyone had this problem using the Ionic cloud package service ?


#16

All of the people posting here had this problem with Ionic Package - this is a thread about a problem with Ionic Package,


#17

Worked for me too…


#18

thank you, this worked for me!


#19

Worked for me! Thank you


#20

Running cordova platform update android@6.2.3 --save worked for me!