Ionic Live Deploy not working


#1

Hi,

I have an existing ionic app and I was hoping to try the ionic live deploy in ionic pro before availing the paid plan, sadly, not successful.

I followed all the procedure in ionic documentation and did the following

*connected my existing app to ionic pro

  • push code to repository (gitlab) and ionic pro
    *set up deploy ( installed cordova-deploy plugin)
    *build my ios ionic app
    *run the latest build in my iphone
    *close app
    *do changes in App content
    *add, commit, push changes to gitlab and ionic pro
    *deployed the latest build to a channel
    *open app- NO CHANGES

I tried installing ionic view and opening the deployed channel and its working

Any idea why the live deploy is not updating the app content (app installed on real device)?

config.xml







package.json
“cordova”: {
“plugins”: {
“ionic-plugin-keyboard”: {},
“cordova-plugin-whitelist”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-ionic-webview”: {},
“cordova-plugin-inappbrowser”: {},
“cordova-plugin-network-information”: {},
“phonegap-plugin-push”: {},
“cordova-plugin-safariviewcontroller”: {},
“cordova-plugin-ionic”: {
“APP_ID”: “14298efd”,
“CHANNEL_NAME”: “Production”,
“UPDATE_METHOD”: “auto”,
“WARN_DEBUG”: “true”,
“UPDATE_API”: “https://api.ionicjs.com”,
“MAX_STORE”: “2”
}

ionic info
cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.19.2
ionic (Ionic CLI) : 3.20.0

global packages:

cordova (Cordova CLI) : 8.0.0 

local packages:

@ionic/app-scripts : 3.1.0
Cordova Platforms  : ios 4.5.4
Ionic Framework    : ionic-angular 3.9.2

System:

ios-deploy : 1.9.2 
ios-sim    : 6.1.2 
Node       : v8.9.4
npm        : 5.8.0 
OS         : macOS High Sierra
Xcode      : Xcode 9.2 Build version 9C40b 

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

Ionic Pro: App version not changes after Deploy Live Updates
#2

I have the same problem. Any help on this issue is kindly appreciated.
When i run my app in Xcode i get the following logs:

2018-04-19 12:52:17.429589+0200 Evisit Scanning[14263:6211236] Zip Extraction: 97%
2018-04-19 12:52:17.431087+0200 Evisit Scanning[14263:6211236] Zip Extraction: 97%
2018-04-19 12:52:17.432376+0200 Evisit Scanning[14263:6211236] Zip Extraction: 97%
2018-04-19 12:52:17.433742+0200 Evisit Scanning[14263:6211236] Zip Extraction: 100%
2018-04-19 12:52:17.441580+0200 Evisit Scanning[14263:6211236] Zip Extraction: 100%
2018-04-19 12:52:17.443671+0200 Evisit Scanning[14263:6211236] Excluding /var/mobile/Containers/Data/Application/53FB2CCD-BAA1-4AB8-9430-CC423A93E9F5/Library/Application Support/ from backup
2018-04-19 12:52:17.443709+0200 Evisit Scanning[14263:6211236] updating version label
2018-04-19 12:52:17.444925+0200 Evisit Scanning[14263:6211236] Unzipped...
2018-04-19 12:52:17.444962+0200 Evisit Scanning[14263:6211236] Removing www.zip 1
2018-04-19 12:52:22.548315+0200 Evisit Scanning[14263:6211477] [BoringSSL] Function boringssl_session_errorlog: line 2881 [boringssl_session_read] SSL_ERROR_ZERO_RETURN(6): operation failed because the connection was cleanly shut down with a close_notify alert

It looks like it’s downloading something but then it fails.


#3

Now i get the following:

2018-04-20 10:12:51.743292+0200 test[15784:6675142] Zip Extraction: 98%
2018-04-20 10:12:51.745084+0200 test[15784:6675142] Zip Extraction: 99%
2018-04-20 10:12:51.746641+0200 test[15784:6675142] Zip Extraction: 99%
2018-04-20 10:12:51.747969+0200 test[15784:6675142] Zip Extraction: 99%
2018-04-20 10:12:51.749521+0200 test[15784:6675142] Zip Extraction: 100%
2018-04-20 10:12:51.753863+0200 test[15784:6675142] Zip Extraction: 100%
2018-04-20 10:12:51.755377+0200 test[15784:6675142] Excluding /var/mobile/Containers/Data/Application/7C8754A9-0B9A-43B3-B85A-D3BA5FA0CE11/Library/Application Support/ from backup
2018-04-20 10:12:51.755416+0200 test[15784:6675142] updating version label
2018-04-20 10:12:51.756690+0200 test[15784:6675142] Unzipped...
2018-04-20 10:12:51.756726+0200 test[15784:6675142] Removing www.zip 1
2018-04-20 10:13:28.447079+0200 test[15784:6675142] uuid is: 35aad04a-aeaa-4100-a0a7-e01dd97efe33
2018-04-20 10:13:28.447179+0200 test[15784:6675142] ignore version: NOTHING_TO_IGNORE
2018-04-20 10:13:28.475279+0200 test[15784:6675499] Redirecting to: file:/var/mobile/Containers/Data/Application/7C8754A9-0B9A-43B3-B85A-D3BA5FA0CE11/Library/Application%20Support/35aad04a-aeaa-4100-a0a7-e01dd97efe33/index.html?cordova_js_bootstrap_resource=/var/containers/Bundle/Application/B7713CA1-C54A-4B42-BCA8-DFF1A170C834/test.app/www/cordova.js
2018-04-20 10:13:28.475439+0200 test[15784:6675142] Reloading the web view.
2018-04-20 10:13:28.506946+0200 test[15784:6675142] Failed to load webpage with error: The operation couldn’t be completed. (NSURLErrorDomain error -999.)

Looks like the extraction is going well, but then it won’t reload the new updated app in the web view.


#4

We are also seeing the -999 error when trying live deploy. The log showed the correct version was downloaded and unzipped but the app was still in an older version - not even the previously deployed version but one version before it (really weird behavior). We have to manually kill the app and relaunch it for quite a few times before the correct version finally shows.


#5

nothing new? same thing happens here.


#6

We received the following updates from the ionic team:

Thanks for your patience while we investigated this issue.

We’ve released version 4.1.5 of cordova-plugin-ionic. Unfortunately the recent 1.2.0 release of cordova-plugin-ionic-webview is incompatible with Deploy. In the near term it will be necessary explicitly force the following versions to use deploy on iOS devices.
“cordova-plugin-ionic-webview”: “1.1.19”,
“cordova-plugin-ionic”: “4.1.5”,

We will continue to work on a permanent solution for deploy on iOS. You’ll be notified via this ticket when we have an update.


#7

I can see that there’s a 1.2.1 release of cordova-plugin-ionic-webview, does this solve the issue?


#8

I’m not sure. But from what we heard the solution isn’t out yet. Also the following updates are recommended:
cordova-plugin-ionic 4.1.6
cordova-plugin-ionic-webview 1.1.19
ionic-app-scripts 3.1.9