Ionic link : [ERROR] API request was successful, but the response format was unrecognized

Good day,

After I created my project and created it alos in the dashboard, I’ve tried to link it, but I get the following error.
Could you please help ?

>ionic link
? What would you like to do? Link an existing app on Ionic Appflow
√ Looking up your apps - done!
? Which app would you like to link CONTROLE G / Perf Tech (41d7940d)
/ Looking up app 41d7940d
[ERROR] API request was successful, but the response format was unrecognized.

    Request: GET https://api.ionicjs.com/apps/41d7940d
    Response: 200
    Body:
    {
    last_activity: '2020-07-02T17:45:59.074380+00:00',
    created: '2020-07-02T17:45:59.074358+00:00',
    updated: '2020-07-02T17:45:59.074374+00:00',
    id: '41d7940d',
    slug: 'perf-tech',
    org_id: '23f40a91-a27e-4012-8175-fdfe05985116',
    dash_metadata: null,
    name: 'Perf Tech',
    icon: 'https://pro-icons-avatars.s3.amazonaws.com/icons/2.png?v=1',
    owner: 2383076,
    org: {
    created: '2020-06-24T08:16:17.032451+00:00',
    _studio_seats: null,
    id: '23f40a91-a27e-4012-8175-fdfe05985116',
    stripe_customer: true,
    description: '',
    avatar: 'https://pro-icons-avatars.s3.amazonaws.com/org/avatar/default_org_icon.png',
    invites: [],
    email: 'dsi@controle-g.com',
    sso: false,
    slug: 'controle-g',
    seats: 2,
    pre_trial_limits_override: {},
    name: 'CONTROLE G',
    product_keys: [],
    trial: false,
    trial_expiration: null,
    trial_creation: null,
    owner: 2383076,
    plan: 'teams'
    },
    repo_url: 'git@git.ionicjs.com:controle-g/perf-tech.git',
    association: {
    app_id: '41d7940d',
    repository: {
    full_name: 'Perf Tech',
    html_url: 'https://gitlab.com/hbek888/perf-tech',
    id: null,
    clone_url: 'https://gitlab.com/hbek888/perf-tech.git',
    type: 'gitlab'
    },
    branches: [ 'master' ],
    user_id: 2383076,
    identity: {
    username: 'hbek888',
    profile: 'https://gitlab.com/hbek888',
    avatars: [Object],
    name: 'Hassan Bekhchouch',
    picture: 'https://secure.gravatar.com/avatar/af3dbe436e7308f29a4db593845a6111?s=80&d=identicon',
    id: 2384622,
    html_url: 'https://gitlab.com/hbek888',
    type: 'gitlab'
    }
    }
    }

Here is my ionic info :slight_smile:

>ionic info

Ionic:

Ionic CLI : 5.4.16 (…\AppData\Roaming\npm\node_modules\ionic)
Ionic Framework : @ionic/angular 5.2.3
@angular-devkit/build-angular : 0.901.10
@angular-devkit/schematics : 9.1.10
@angular/cli : 9.1.10
@ionic/angular-toolkit : 2.2.0

Capacitor:

Capacitor CLI : 2.2.1
@capacitor/core : 2.2.1

Utility:

cordova-res : 0.11.0
native-run : 1.0.0

System:

NodeJS : v12.18.1 (C:\Program Files\nodejs\node.exe)
npm : 6.14.4
OS : Windows 10

Thanks a lot

2 Likes

I also have the same issue and it looks like the config file is not updated with the app id. When I run then ionic build package I am still asked to link the app.
This is a problem as I need to build the package in a CI