Ionic ios shell script invocation error


#1

Hi,
I’m having a trouble trying to run ionic project on ios.
Before, it was working fine, I’ve even installed on device for debug. But when I got new updates from git (because I made changes in another computer) its ocurring a “Shell Script Invocation Error” on xcode, below:

PhaseScriptExecution Copy\ www\ directory /Users/P.Benedetti/Library/Developer/Xcode/DerivedData/Ideia$_-_Gestor_Financeiro-fauofftffgwajgcchbuygpefynrb/Build/Intermediates/Ideia$\ -\ Gestor\ Financeiro.build/Debug-iphonesimulator/Ideia$\ -\ Gestor\ Financeiro.build/Script-304B58A110DAC018002A0835.sh cd /Users/P.Benedetti/Desktop/XCODE/gf_ios/platforms/ios /bin/sh -c \"/Users/P.Benedetti/Library/Developer/Xcode/DerivedData/Ideia$_-_Gestor_Financeiro-fauofftffgwajgcchbuygpefynrb/Build/Intermediates/Ideia$\ -\ Gestor\ Financeiro.build/Debug-iphonesimulator/Ideia$\ -\ Gestor\ Financeiro.build/Script-304B58A110DAC018002A0835.sh\"
/bin/sh: /Users/P.Benedetti/Library/Developer/Xcode/DerivedData/Ideia/bin/sh-_Gestor_Financeiro-fauofftffgwajgcchbuygpefynrb/Build/Intermediates/Ideia$ - Gestor Financeiro.build/Debug-iphonesimulator/Ideia$ - Gestor Financeiro.build/Script-304B58A110DAC018002A0835.sh: No such file or directory

I’ve tried enter this folder, but the folder “bin” inside “Ideia” folder does not exist. I thought it could be that ionic/cordova was not creating this folder/script. Another thing I think it could be is that the name of my project has special chacters and space. I’ve tried update ionic/cordova, ios-sim, remove/add ios platform, but nothing.

I’m using Mac OS Sierra and Xcode Version 8.0 (8A218a).

Hope someone can give a light.