Ionic ios app not emulating to ios simulator through cli commands


I am starting to create new app with latest ionic version.

I got the following info through ionic info command


   Ionic CLI                     : 6.1.0 (/usr/local/lib/node_modules/@ionic/cli)
   Ionic Framework               : @ionic/angular 5.0.0
   @angular-devkit/build-angular : 0.803.25
   @angular-devkit/schematics    : 8.3.25
   @angular/cli                  : 8.3.25
   @ionic/angular-toolkit        : 2.1.2


   Cordova CLI       : not installed
   Cordova Platforms : not available
   Cordova Plugins   : not available


   cordova-res : not installed
   native-run  : 0.3.0


   ios-deploy : 1.10.0
   ios-sim    : 8.0.2
   NodeJS     : v12.16.0 (/usr/local/bin/node)
   npm        : 6.13.7
   OS         : macOS Catalina
   Xcode      : Xcode 11.3.1 Build version 11C504

I just followed the following steps

npm install -g @ionic/cli
ionic start myApp tabs
cd myApp
ionic serve

when i run ionic serve i get the web page opened automatically.

and then i have added the ios developer account to the xcode

xcode-select --install
npm install -g ios-sim
brew install ios-deploy
ionic cordova prepare ios
ionic cordova run ios -l --external

so finally when i run the cli command. I get the simulator opened automatically and some popup verifying and close after few seconds after that app not installed in simulator.

It works when I run manually from xcode.

Please help me to get the “ionic cordova run ios -l --external” command run successfully.

Thanks for all