Ionic app wont load in IOS simulator (The App Server is not running)

#1

Hi Guys,

I am currently working on an Ionic 3 project, this project builds and works fine on IOS devices and Android Device, however when I use any IOS simulator using xCode or using the Ionic emulate command, I get the error below.

I have tried to run prod builds, removed IOS and added again, I have enabled COREs on my server etc, and search the net but nothing seems to come up!


Ionic:

ionic (Ionic CLI) : 4.2.1 (/usr/local/lib/node_modules/ionic)
Ionic Framework : ionic-angular 3.9.2
@ionic/app-scripts : 3.2.1

Cordova:

cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
Cordova Platforms : android 7.1.4, browser 5.0.4, ios 4.5.5
Cordova Plugins : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 2.2.1, (and 8 other plugins)

System:

Android SDK Tools : 26.1.1 (/Users/billy/Library/Android/sdk)
ios-deploy : 2.0.0
NodeJS : v8.9.1 (/usr/local/bin/node)
npm : 6.4.1
OS : macOS
Xcode : Xcode 10.1 Build version 10B61

#2

Something similar happed to me as well. That is when I ran the app on the browser and emulator at the same time using the same port number. Maybe it’s unrelated, I don’t know.

#3

Hi, thank you for your reply, I have tried this also, stopped the ionic serve, and then ran the emulator, however same issue, I will test this further by stopping docker and seeing if that helps

#4

Looks like it was my Docker that was causing the issue, I stopped all my docker instances and that fixed the issue, thank you