Ionic input / textarea spellcheck or auto-complete on Android?

I’m trying to enable some form of auto-correction for ion-input and ion-textarea components in an Ionic 2 app. Regardless of what I try, all forms of spell checking and assistance seem to be disabled in the app. I’m struggling to find any information on the topic - the only questions that pop up seem to be asking the opposite (i.e. how to disable spell check).

The target Android version is 4.4, but I’ve also tested quickly on 6.0. Regardless of what Android’s auto-correction is set to (e.g. Aggressive), and with Word suggestions set to on, none of these features seem to be invoked inside the resulting Ionic app at all. The user just gets a basic keyboard, no warnings about spelling, word suggestions, auto-correction, etc. I’ve tested the keyboard settings in the SMS editor as well as Chrome / Android browser to ensure they are taking effect, and they are. So the effect seems to be limited to the WebView used by Ionic / Cordova.

This was starting to sound like more of a Cordova topic, but searching in that context also was fruitless.

Does anyone have further info on the topic, or a solution? Thanks in advance.

3 Likes

just add autocomplete=“true” spellcheck=“true” to ion input or text area and it should work

6 Likes

Thanks, this worked.

Thx !!! You are the best

This doesn’t work for me on ios with the latest verison of ionic 2. There’s no predictive text and also no spell check enabled.

yes i have the same problem with ios

any update on this? Not working for me either.

1 Like

Some news about this issue ?

use autocomplete=“on” instead of autocomplete=“true”.

3 Likes

Unfortunately, it still does not work on IOS …

I try it on a “ion-textarea” :

<ion-textarea spellcheck="true" autocomplete="on" type="text" fz-elastic name="description" ngModel></ion-textarea>

try with autocorrect=“on” instead of spellcheck=“true”

7 Likes

It’s work :slight_smile: Thanks a lot.

4 Likes

This should be the top accepted answer now :slight_smile:

Hi bro! It worked for input type=“text” but unfortunately it is not working for input type email. Is there any solution for that?
Any help will be appreciated :slight_smile: