Ionic info shows an error


#1

Hi

I see an error in my config but I don’t know how to fix it, can you help please?

$ ionic info
[ERROR] Error with
        /home/louisro/Documents/mobileApps/BoardLine/ionic_version/www/lib/ionic/version.json
        file: FILE_NOT_FOUND

global packages:

    @ionic/cli-utils : 1.4.0
    Cordova CLI      : 6.5.0 
    Gulp CLI         : CLI version 3.9.1 Local version 3.9.1
    Ionic CLI        : 3.4.0

local packages:

    @ionic/cli-plugin-cordova : 1.4.0
    @ionic/cli-plugin-gulp    : 1.0.1
    @ionic/cli-plugin-ionic1  : 2.0.0
    Cordova Platforms         : android 6.2.3 ios 4.3.1
    Ionic Framework           : unknown

System:

    Node       : v7.4.0
    OS         : Linux 4.4
    Xcode      : not installed
    ios-deploy : not installed
    ios-sim    : not installed
    npm        : 4.0.5

and package.json should not have “@ionic/cloud-angular”: “^0.4.0”, for ionic v1, should it ?

package.json:

{
  "name": "boardapp",
  "app_id": "bc689f0f",
  "version": "1.0.0",
  "description": "newIonic: An Ionic project",
  "dependencies": {
    "@ionic-native/globalization": "^3.2.0",
    "@ionic/cloud": "^0.9.0",
    "@ionic/cloud-angular": "^0.4.0",
    "bluebird": "^3.4.6",
    "gulp": "^3.5.6",
    "gulp-concat": "^2.2.0",
    "gulp-minify-css": "^0.3.0",
    "gulp-rename": "^1.2.0",
    "gulp-sass": "^2.0.4",
    "ionic-app-lib": "^2.2.0"
  },
  "devDependencies": {
    "@ionic/cli-plugin-cordova": "1.4.0",
    "@ionic/cli-plugin-gulp": "1.0.1",
    "@ionic/cli-plugin-ionic1": "2.0.0",
    "bower": "^1.3.3",
    "gulp": "^3.9.1",
    "gulp-replace-task": "^0.11.0",
    "gulp-util": "^3.0.7",
    "shelljs": "^0.3.0",
    "yargs": "^5.0.0"
  },
  "cordovaPlugins": [
    {
      "locator": "https://github.com/VitaliiBlagodir/cordova-plugin-datepicker.git",
      "id": "cordova-plugin-datepicker"
    },
    "ionic-plugin-deploy",
    "cordova-plugin-extension",
    "cordova-plugin-admobpro",
    "cc.fovea.cordova.purchase",
    "onesignal-cordova-plugin",
    "cordova-plugin-geolocation",
    "cordova-plugin-device",
    "cordova-plugin-network-information",
    "cordova-plugin-compat",
    "cordova-plugin-app-version",
    "cordova-plugin-console",
    "cordova-plugin-globalization",
    "cordova-plugin-google-analytics",
    "cordova-plugin-googleplus",
    "cordova-plugin-splashscreen",
    "cordova-plugin-statusbar",
    "cordova-plugin-whitelist",
    "cordova-plugin-x-socialsharing",
    "ionic-plugin-keyboard",
    {
      "id": "cordova-plugin-facebook4",
      "locator": "cordova-plugin-facebook4",
      "variables": {
        "APP_ID": "583996261696416",
        "APP_NAME": "Boardapp"
      }
    }
  ],
  "cordovaPlatforms": [
    "android@6.1.0",
    {
      "platform": "android",
      "version": "",
      "locator": "android"
    }
  ],
  "main": "gulpfile.js",
  "scripts": {},
  "repository": {
    "type": "git",
    "url": "git+https://LouisDoe@bitbucket.org/boardappdevs/boardapp.git"
  },
  "author": "",
  "license": "ISC",
  "homepage": "https://bitbucket.org/boardappdevs/boardlapp#readme"
}

Documentation on Android SDK
#2

Having the same issue here. I guess the bug is from ionic cli 2.0.0. Any updates here?


#3

Does the file actually not exist?
A similar one?[quote=“LouisR, post:1, topic:95124”]
and package.json should not have “@ionic/cloud-angular”: “^0.4.0”, for ionic v1, should it ?
[/quote]

Exactly, this should go: npm uninstall @ionic/cloud-angular

And I don’t know if Ionic Native 3.x is working with Ionic v1 - you should research that.


#4

CLI 2.0.0? You should definitely update to 3.x.


#5

I resolved my problem. I don’t really want to upgrade to Ionic CLI 3 as I’m only using Ionic 1. Ionic CLI 3 deprecates a few commands and features that I get used to using Ionic CLI 2.

In case someone is having the same problem and don’t want to learn and deal with the new Ionic CLI 3, here are the commands

npm uninstall cordova ionic
npm install -g cordova@6.5.0 ionic@2.2.3

#6

Thanks for your answer.

Actually, the file /home/louisro/Documents/mobileApps/BoardLine/ionic_version/www/lib/ionic/version.json doesn’t exist…what should I do ?

I just ran npm uninstall @ionic/cloud-angular. But I still have "@ionic/cloud-angular": "^0.4.0", in package.json.

Where can I find the info wheter Ionic Native 3 works with ionic v1 ?


#7

Find out if it should exist. Create a new ionic v1 proect and compare.[quote=“LouisR, post:6, topic:95124”]
I just ran npm uninstall @ionic/cloud-angular. But I still have “@ionic/cloud-angular”: “^0.4.0”, in package.json.
[/quote]

Sorry, have to add --save probably.[quote=“LouisR, post:6, topic:95124”]
Where can I find the info wheter Ionic Native 3 works with ionic v1 ?
[/quote]

Read the docs, maybe create a topic and ask. Most people use ngCordova with Ionic v1 I think, not Ionic Native.