Ionic DevApp: Unable to load page (solved)

#1

The error is show in my iPhone iOS v.11.2.5 (15D60) from this morning for all the apps i tried, even for a basic blank app

Regards.

#2

Nobody uses DevApp with iphone?

1 Like
#3

I do, but had no part in creating DevApp. Nor am I a maintainer of DevApp. The same probably goes for everyone else on the forum. Most likely, no one has a clue as to why it bugs out or what to do about it, unfortunately.

You’d probably have to contact official Ionic support for cases like this.

#4

At least now I know that what happens to me is not something general.

Thank you, @jaydz.

Update: My iPad behaves like my iPhone: DevApp lists the ionic served apps, but is unable to run it (blank page+error showed in first post).
I will try to explore the port numbers used by devApp on these devices and to check in the firewall.

#5

Solved!

In previous days, my ISP changed the security settings of my router settings. I have reconfigured it to my previous custom values and Apple devices are now able to run applications in devapp from my computer.

Do not trust your ISP too much … :sweat_smile:

1 Like
DevApp: Unable to load page (solved again)
#6

Are you able to share which settings you changed on your router? I am having the exact same issue and can’t seem to figure out how to get it working.

#7

Hi @psnfrech. Forget the router, Probe with:

ionic serve -c --no-proxy

Greetings.
Juan.

#8

Hello @Juan-ionic

It didn’t work for me. Do you have any other solution?

#9

Sorry, @pedronunesfx. This month I stopped doing tests. In this thread is all the information i have. Good luck.

#10

Hi,

just had the same issue and solved it by changing my wifi

My network config is : one internet box (freebox in France) + one TP-Link routeur linked together via ethernet cable
my computer and my iphone are connected to the TPlink router because the wifi spped is definitively better

=> it was the issue

when I run the ionic serve => browser works fine via the local host
but any device iphone 5S and SE get the message unable to load the page (the request time out)

it was due to the routeur, I just switch my laptop and my iphone to the wifi provided by my internet box and everything is fine now :slight_smile:
I need to check is port 8100 is opened on y routeur, but seems not :thinking:

I send couple of hours to install / desintall / reinstall…

hope it will help few of you

sorry for the beginner way I describe my issue I coded html /php/action script 15 years ago, and start ionic since yesterday :wink:

Br,
Flyhooo

#11

you are turn off firewall on your computer

3 Likes
#12

Thanks.
For me, I am using Windows 10. I have to switch my network to private first (instead of public). Then turn off Firewall as well. It seems Port default ionic 8100 has issue on network.

#13

Hi,

I also faced the same issue on Windows 10.

You need to do a two step process.

  1. Add a inbound rule in your Windows Defender Firewall Advanced Settings that will allow the port (8100 in my case) to be open for access. Here make sure to set the rule to allow only for private network (so that your computer is protected).

  2. Then make sure that your Wifi Connection network profile on your PC is marked private.
    This can be done by accessing
    Right Click on Wifi Connection at the right bottom, open Network and Internet Settings, click status, then click Change Connection Properties and you will find the Network Profile there.

If you are using it in a public wifi setup then change the private to public on both steps. This is not recommended.

Regards,

SD

1 Like
#14

thank you so much you saved my life

#15

I have the same issue. I enter the ip adress manually and it wokrs on me.

Capture

#16

Thanks Cheyseth
This worked for me too…