Ionic DevApp ERR_ADDRESS_UNREACHABLE

I’m trying to use the new Ionic Dev App.

When I try to load the app, on IOS the screen is just blank white.

On Android, I get the following message:

Webpage Not Available
The webpage at http://10.0.0.4:8100/?devapp=true could not be loaded because:

net:::ERR_ADDRESS_UNREACHABLE

3 Likes

I am having the same problem!
Any help?

Same here.

Linux Mint for Ionic
OnePlus 5 for the DevApp

use --local with ionic serve, or apparently this will be fixed in the next update

1 Like

texasman03 - Thank you :slight_smile:

using --local does not create a ionicdevapp server, only does the localhost.

Is this issue resolved or has anyone found a fix for it?
The app is not shown in my iOS device

What worked for me is :
I created hotspot with one of my mobile devices.
Connected all my necessary devices to this network. And the app worked in Ionic DevApp

turning off my firewall helped to solve this.

3 Likes

run the command ionic serve -c

This worked for me, thanks

It works to me :smiley:

Ionic DevApp is deprecated. We no longer offer any “on device” apps that serve this purpose. Instead we’ve added the Web Preview feature to Appflow. Web Previews can be used to share you web app without native features. Think of it like a cloud based ionic serve. You won’t have access to native plugins but that was an issue even in DevApp.