Ionic cordova-plugin-googleplus error 10

Hi

This is my first Ionic and Firebase project that I am working on and I am trying to implement native Google oAuth by using the plugin found here: https://github.com/EddyVerbruggen/cordova-plugin-googleplus

I’ve tried doing this using multiple tutorials such as:


My problem is that I keep on getting “Error: 10”

[12:39:31]  console.log: Angular is running in the development mode. Call enableProdMode() to enable the production
            mode.
[12:39:31]  console.log: deviceready has not fired after 5 seconds.
[12:39:31]  console.log: Ionic Native: deviceready event fired after 3588 ms
[12:39:39]  console.error: 10
[12:39:48]  build started ...
[12:39:48]  transpile update started ...
[12:39:48]  transpile update finished in 220 ms
[12:39:48]  deeplinks update started ...
[12:39:49]  deeplinks update finished in 575 ms
[12:39:49]  webpack update started ...
[12:39:51]  webpack update finished in 2.32 s
[12:40:01]  build finished in 13.14 s

[12:40:07]  console.log: Angular is running in the development mode. Call enableProdMode() to enable the production
            mode.
[12:40:07]  console.log: deviceready has not fired after 5 seconds.
[12:40:07]  console.log: Channel not fired: onPluginsReady
[12:40:07]  console.log: Channel not fired: onCordovaReady
[12:40:08]  console.log: Ionic Native: deviceready event fired after 3363 ms
[12:40:13]  console.error: 10

Is there any way that I could somehow find out more information regarding this error as right now nothing I am trying is fixing the problem? Maybe some additional debugging or something so that I can establish where exactly my problem is coming from?

I have signed my APK using a cert I’ve generated and made sure that I’ve used the SHA1 from the cert. As well as I’ve made sure that I’m using the client ID found here: https://console.developers.google.com/apis/credentials which corresponds to my SHA1 hash.

Any ideas or help would be greatly appreciated, I’ve been on at this for days and am not making any headway.

Thanks so much!

I’m with this same issue.