"ionic Cordova build iOS --prod" not working properly

When I run "Ionic Cordova build ios --prod " it is not working properly.?
It makes the build but when I run it on mobile then all pages of application become one page. and no sass is applied on them.

“cordova build ios --prod” is working properly but it is taking too much time on splash screen.

How can I solve that problem ?

Please post the complete output of ionic cordova build ios --prod.
Please post your ionic info output.

cordova build ios --prod is doing the exact same thing minus the Ionic build before the Cordova build. Normally it shouldn’t behave different on the device.

I recently had an issue with build (where serve worked fine) that was resolved just by removing and re-adding the ios platform.
It’s a crude and non-specific solution (the equivalent of turning it off and on again) but sometimes it works :slight_smile:

So do you find the permanent solution ?

ionic cordova platform rm ios

ionic cordova platform add ios

Is all it took in my case