APP stuck on splash screen when using –prod (IOS 10 or lower)


#1

The app works fine in both android and ios (11.3 or hight), when I used to run the app using commands:
ionic cordova build ios
But as soon as I run the app using ‘–prod’ in front of them the app used to get stuck on my splash
My ionic info prints this:

`cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.19.2
ionic (Ionic CLI) : 3.20.0

global packages:

cordova (Cordova CLI) : 8.0.0 

local packages:

@ionic/app-scripts : 3.1.8
Cordova Platforms  : ios 4.5.4
Ionic Framework    : ionic-angular 3.9.2

System:

ios-deploy : 1.9.2 
ios-sim    : 6.1.2 
Node       : v8.10.0
npm        : 5.6.0 
OS         : macOS High Sierra
Xcode      : Xcode 9.3 Build version 9E145 

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

`
I got this in my safari debugger. Maybe this would help you out…!a94788ba9875f1f3a569428be7584bd717bf46e3_1_690x149
I run on IOS 11.3 no problem, but with IOS 10 or lower and using flag “–prod” then error.