Ionic Cli Serve Lab Url


#1

Hello,

I have a difficulty that is driving me crazy … I downloaded a Vm with NodeJs in Bitnami, I installed Ionic to test/learn, but when I start the ionic serve, I can’t change the input url of the ionic-lab … As a result, when accessing the ionic-lab, the simulations are trying to access localhost:8100. I’m trying to change localhost to 192.168.15.100 (ip of VM).

Example:

bitnami@vmNodeJs:~/projects/cobaia$ ionic serve --lab --lab-host 192.168.15.100 --address 192.168.15.100
> ionic-app-scripts serve --address 192.168.15.100 --port 8100 --livereload-port 35729 --dev-logger-port 53703 --nobrowser
[app-scripts] [11:32:11]  ionic-app-scripts 3.1.11
[app-scripts] [11:32:11]  watch started ...
[app-scripts] [11:32:11]  build dev started ...
[app-scripts] [11:32:11]  clean started ...
[app-scripts] [11:32:11]  clean finished in 4 ms
[app-scripts] [11:32:11]  copy started ...
[app-scripts] [11:32:11]  deeplinks started ...
[app-scripts] [11:32:11]  deeplinks finished in 24 ms
[app-scripts] [11:32:11]  transpile started ...
[app-scripts] [11:32:17]  transpile finished in 6.11 s
[app-scripts] [11:32:17]  preprocess started ...
[app-scripts] [11:32:17]  preprocess finished in 1 ms
[app-scripts] [11:32:17]  webpack started ...
[app-scripts] [11:32:18]  copy finished in 6.32 s
[app-scripts] [11:32:26]  webpack finished in 8.19 s
[app-scripts] [11:32:26]  sass started ...
[app-scripts] Without `from` option PostCSS could generate wrong source map and will not find Browserslist config. Set it to CSS file path or to `undefined` to prevent this warning.
[app-scripts] [11:32:28]  sass finished in 1.88 s
[app-scripts] [11:32:28]  postprocess started ...
[app-scripts] [11:32:28]  postprocess finished in 35 ms
[app-scripts] [11:32:28]  lint started ...
[app-scripts] [11:32:28]  build dev finished in 16.43 s
[app-scripts] [11:32:28]  watch ready in 16.71 s
> ionic-lab http://localhost:8100 --host 192.168.15.100 --port 8200 --app-name helpDriver --app-version 0.0.1

[INFO] Development server running!

       Lab: http://192.168.15.100:8200
       Local: http://localhost:8100
       DevApp: helpDriver@8100 on vmNodeJs

       Use Ctrl+C to quit this process

[INFO] Browser window opened to http://192.168.15.100:8200!

[app-scripts] [11:32:32]  lint finished in 4.22 s
^C
[ERROR] A utility CLI has unexpectedly closed (exit code null).

        The Ionic CLI will exit. Please check any output above for error details.

bitnami@vmNodeJs:~/projects/cobaia$ ./node_modules/.bin/ionic-lab --help

  ionic-lab

  Usage:

    $ ionic-lab <url> [options]

  Inputs:

    url ...................... The URL of the livereload server to use with lab

  Options:

    --host ................... HTTP host of Ionic Lab (default: localhost)
    --port ................... HTTP port of Ionic Lab (default: 8200)
    --ssl .................... Host Ionic Lab with HTTPS
    --ssl-key ................ Path to SSL key
    --ssl-cert ............... Path to SSL certificate
    --app-name ............... App name to show in bottom left corner
    --app-version ............ App version to show in bottom left corner

Is it possible to change the value of the url when calling the ionic serve?
I even looked for other posts on this case, but the ones I encountered were different problems. Sorry if I duplicated.


#2

Did you ever get a solution to this, i’ve run into the exact same problem