Ionic CLI error after 3.6.0 update

on ionic serve, it prompted me if I wanted the CLI to automatically check for updates in the background.

Then it came with the error as below:


It breaks the CLI and I cannot do ionic serve since then.

ionic info had same error output.

ionic info --verbose:

D:\MyCloud\git\cow-v2>ionic info --verbose
[DEBUG] CLI flags: { interactive: true, confirm: false }
[DEBUG] { cwd: 'D:\\MyCloud\\git\\cow-v2', local: true, binPath:
        'C:\\Users\\Adrian\\AppData\\Roaming\\npm\\node_modules\\ionic\\bin\\ionic', libPath:
        'D:\\MyCloud\\git\\cow-v2\\node_modules\\ionic\\dist\\index.js' }
[DEBUG] Loading local plugin @ionic/cli-plugin-proxy
[DEBUG] Throwing PLUGIN_NOT_INSTALLED for local @ionic/cli-plugin-proxy
[DEBUG] Loading local plugin @ionic/cli-plugin-ionic-angular
[DEBUG] Getting plugin info for ionic
[DEBUG] Checking for latest plugin version of ionic@latest.
[DEBUG] Getting plugin info for @ionic/cli-plugin-ionic-angular
[DEBUG] Checking for latest plugin version of @ionic/cli-plugin-ionic-angular@latest.
[DEBUG] New daemon pid: 39216

      throw er; // Unhandled 'error' event

Error: spawn C:\Program Files\nodejs\node.exe ENOENT
    at notFoundError (D:\MyCloud\git\cow-v2\node_modules\cross-spawn\lib\enoent.js:11:11)
    at verifyENOENT (D:\MyCloud\git\cow-v2\node_modules\cross-spawn\lib\enoent.js:46:16)
    at ChildProcess.cp.emit (D:\MyCloud\git\cow-v2\node_modules\cross-spawn\lib\enoent.js:33:19)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12)


  "name": "cow-v2",
  "version": "0.0.1",
  "author": "Ionic Framework",
  "homepage": "",
  "private": true,
  "scripts": {
    "clean": "ionic-app-scripts clean",
    "build": "ionic-app-scripts build",
    "lint": "ionic-app-scripts lint",
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  "dependencies": {
    "@angular/common": "4.1.3",
    "@angular/compiler": "4.1.3",
    "@angular/compiler-cli": "4.1.3",
    "@angular/core": "4.1.3",
    "@angular/forms": "4.1.3",
    "@angular/http": "4.1.3",
    "@angular/platform-browser": "4.1.3",
    "@angular/platform-browser-dynamic": "4.1.3",
    "@ionic-native/core": "3.12.1",
    "@ionic-native/splash-screen": "3.12.1",
    "@ionic-native/status-bar": "3.12.1",
    "@ionic/storage": "2.0.1",
    "font-awesome": "^4.7.0",
    "ionic-angular": "3.5.0",
    "ionicons": "3.0.0",
    "rxjs": "5.4.0",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.12"
  "devDependencies": {
    "@ionic/cli-plugin-ionic-angular": "1.4.0",
    "ionic": "3.6.0",
    "typescript": "2.3.4"
  "description": "An Ionic project",
  "config": {
    "ionic_copy": "./scripts/copy-custom-libs.js"

Can someone tell me what it meant and what should I do to get this working?

I hv followed the following tutorial to install font-awesome in the project:

it involves moving the copy.config.js file to a new location.
I wondered if this breaks the above operation some how.

If the way of how font awesome is implemented in the above tutorial wasn’t best practice, please also let me know what should be…

I created an issue for this error:

1 Like

I now reverse to CLI 3.5.0 to continue with the project.
but how do i know when 3.6.0 is fixed and safe to use?

Same problem here after update to 3.6.0

You watch the issue on Github that I created.

Can you share some information? What is the output you get? When do you get the error? Does ionic info work? If not, can you manually collect the information - especially OS, node and npm version?


I am following the post on github but I am new to it so may not fully understand how it works there.

It is marked as bug now, will the mark change or a new label be added to it when the bug is fixed?
or the issue tag will turn from “open” to “close” when it is okay?

sorry i know this sounds like a stupid question. I jsut want to know when is save to use 3.6.0, every now and then i fear i press the wrong button and upgraded my CLI when it prompt me on ionioc serve :stuck_out_tongue_closed_eyes:

It will be closed when a fix is implemented. showed a workaround that worked for me.