Ionic cli broken on windows after updating to 1.7.1


#1

I had been working with ionic all day and at the end of the day the cli notified me that there was a new version available and so I ran npm install -g ionic as instructed.
The installation failed with the error posted below. All following attempts to reinstall ionic failed with the same error, cmd was ran as administrator.
All other npm installs I tried worked fine, so I’m assuming this is an ionic issue, perhaps something broken in the latest version?

npm install -g ionic

spawn-sync@1.0.13 postinstall C:\Users\Ideativity\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib\node_modules\cross-spawn\node_modules\spawn-sync
node postinstall

node-sass@3.3.3 install C:\Users\Ideativity\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib\node_modules\node-sass
node scripts/install.js

Binary downloaded and installed at C:\Users\Ideativity\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib\node_modules\node-sass\vendor\win32-x64-14\binding.node

node-sass@3.3.3 postinstall C:\Users\Ideativity\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib\node_modules\node-sass
node scripts/build.js

C:\Users\Ideativity\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib\node_modules\node-sass\vendor\win32-x64-14\binding.node exists.
testing binary.
Binary is fine; exiting.
npm WARN engine cordova-js@4.0.0: wanted: {“node”:"~0.10.x"} (current: {“node”:“0.12.7”,“npm”:“2.11.3”})
npm WARN engine xmlbuilder@2.2.1: wanted: {“node”:“0.8.x || 0.10.x”} (current: {“node”:“0.12.7”,“npm”:“2.11.3”})
npm ERR! Windows_NT 6.3.9600
npm ERR! argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “install” “-g” "ionic"
npm ERR! node v0.12.7
npm ERR! npm v2.11.3
npm ERR! path C:\Users\Ideativity\AppData\Roaming\npm\ionic
npm ERR! code EPERM
npm ERR! errno -4048

npm ERR! Error: EPERM, open 'C:\Users\Ideativity\AppData\Roaming\npm\ionic’
npm ERR! at Error (native)
npm ERR! { [Error: EPERM, open ‘C:\Users\Ideativity\AppData\Roaming\npm\ionic’]
npm ERR! errno: -4048,
npm ERR! code: ‘EPERM’,
npm ERR! path: ‘C:\Users\Ideativity\AppData\Roaming\npm\ionic’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.
npm ERR! error rolling back Error: EPERM, lstat 'C:\Users\Ideativity\AppData\Roaming\npm\ionic’
npm ERR! error rolling back at Error (native)
npm ERR! error rolling back { [Error: EPERM, lstat ‘C:\Users\Ideativity\AppData\Roaming\npm\ionic’]
npm ERR! error rolling back errno: -4048,
npm ERR! error rolling back code: ‘EPERM’,
npm ERR! error rolling back path: ‘C:\Users\Ideativity\AppData\Roaming\npm\ionic’ }

npm ERR! Please include the following file with any support request:
npm ERR! D:\cygwin64\home\Ideativity\npm-debug.log


#2

Am getting the samme error to after update. Did you find any solution to this?


#3

No, but check witch npm version you have, from what I could tell only 0.12.7 works, also try rebooting your pc. If that doesn’t help, you might have to do what I did, which was fully delete everything npm related, I did it somewhat iteratively so with a few reboots in between, and then reinstall everything.
I understand this method might not be acceptable for everyone though.