Ionic build ios error

Hi everyone. I’m new to using the Ionic Framework. My dad, who is a software engineer, recommended installing it and getting it set up, which I managed to do. Since I am running Windows, I created a VM with Yosemite using VMware. I’m extremely confused, because when we both run the command ionic info it shows the exact same information for both of us. The thing is, he has a real Macbook and I have a VM.

Here is what ionic info returns:

OS: Mac OS X Yosemite
Node Version: v0.12.2
Cordova CLI: 5.0.0
Ionic Version: 1.0.0-rc.4
Ionic CLI Version: 1.3.20
Xcode version: Xcode 6.3.1 Build version 6D1002
ios-sim version: 3.1.1
ios-deploy version: Not installed

As I aforementioned, we both have the same exact information displaying from the command and for some reason when he runs ionic build it works for him with no errors, but I receive errors.

Here are the errors:


The following build commands failed:
CompileC build/ Classes/NSDictionary+Extensions.m normal i386 objective-c
CompileC build/ Classes/CDVInvokedUrlCommand.m normal i386 objective-c
(2 failures)
Error code 65 for command: xcodebuild with args: -xcconfig,/Users/federico/Learning/Ionic/luna/platforms/ios/cordova/build-debug.xcconfig,-project,luna.xcodeproj,ARCHS=i386,-target,luna,-configuration,Debug,-sdk,iphonesimulator,build,VALID_ARCHS=i386,CONFIGURATION_BUILD_DIR=/Users/federico/Learning/Ionic/luna/platforms/ios/build/emulator,SHARED_PRECOMPS_DIR=/Users/federico/Learning/Ionic/luna/platforms/ios/build/sharedpch
ERROR building one of the platforms: Error: /Users/federico/Learning/Ionic/luna/platforms/ios/cordova/build: Command failed with exit code 2
You may not have the required environment or OS to build this project
Error: /Users/federico/Learning/Ionic/luna/platforms/ios/cordova/build: Command failed with exit code 2
at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:131:23)
at ChildProcess.emit (events.js:110:17)
at maybeClose (child_process.js:1015:16)
at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

We both simultaneously searched for solutions and applied them to no avail unfortunately. My last resort was to post here hoping someone more experienced than me could help out. I would greatly appreciate it.

Would it have anything to do with the fact that this Yosemite is vanilla? I haven’t updated it. I doubt it, but just a thought.

VMWARE don’t fully use specs of processor and microcodes. maybe this a problem clang use processor microcodes to compile

look at message

You may not have the required environment or OS to build this project

I have gotten ionic working in Mac VMs before although not with Xcode 6.3.

Have you checked that Xcode Command Line tools are installed within your VM? From memory just type ‘gcc’ in the command shell as shown in

1 Like

Sorry for the late reply. Yes, Xcode Command Line Tools are installed. I downloaded Xcode 6.2, but no difference. Even reinstalled the VM with everything fresh also.

Same error here. Anyone had solved problem?