Ionic Angular Web app doesn't render in iPhones


I made a web app with ionic angular that runs as intended in all web browsers and android browsers but breaks or renders a white screen in iPhones with iOS v13 or lower. iPads work and modern iPhones (with iOS 14 & greater) render the site successfully. This is the website. (its under construction so it looks wonky :P)

There are no console errors and I’m pretty sure its something with some new version of some package, but I just cant pin point what or which it is! I have two other projects made about a month or two ago that work great in all iOS devices. These are them for reference: CyberJibaNFT Website & CryptoBangersNFT Unlockables Site

I’m currently testing using Browserstack so I’m pretty sure the devices im testing on are fully updated.

These are my packages.

A million thanks for any help!

Angular, by default, only supports latest 2 versions of iOS (3 at the moment since iOS 16 is official), that’s from 14 to 16.

To support iOS 13 you have to compile for es5, see Mobile Browser Support to Run Ionic Apps Anywhere


Thanks for the quick reply! You gave me hope that im on the right track. I actually tried recompiling the project with es2015 since my working projects are compiled using es5, but still getting a blank page.

I was just able to get the page running by replacing es2015 for ES5. Swore they were interchangeable.

Thanks a lot ionic team! :zap::zap::zap:

Actually I might have spoken too soon. I tested my app in 5 different iPhones and only the ones with iOS 14, 15 and 16 are working as stated in the first response. The others arent rendering the site.

This is my tsconfig.json

And these are the commands I’m using to recompile my project.

ng build --configuration production


ng build --ts-config ./tsconfig.json --configuration production

I know the problem is something stupid but I just cant seem to find what it is! Also dont wanna just copy/paste my working project to have my new one work cause thats caca and i know this project is fixable.

Thanks again yall! :zap::fire:

PS. The “lib” value was es2018 default but changed it to es2015 just in case that worked.