Ionic app (Cordova/Angular) works on iPhone but not iPad

My Ionic app stopped working on iPad but continues to work flawlessly on iPhone and all other devices. I’ve been removing plugins and tweaking version numbers to no avail.

When I run on iPad some services are not constructed (most importantly the UserService) so the app is stuck on a loading screen as it tries to load the authentication state and user.

I’m hoping someone has some idea of what could even cause a problem like this because I haven’t been able to find anyone else on the internet facing this issue.

Here is the full list of dependencies:

    "@angular/common": "^14.0.0",
    "@angular/core": "^14.0.0",
    "@angular/fire": "^7.4.1",
    "@angular/forms": "^14.0.0",
    "@angular/platform-browser": "^14.0.0",
    "@angular/platform-browser-dynamic": "^14.0.0",
    "@angular/router": "^14.0.0",
    "@ionic-native/camera": "^5.36.0",
    "@ionic-native/core": "^5.0.0",
    "@ionic-native/firebase-messaging": "^5.36.0",
    "@ionic-native/google-plus": "^5.31.1",
    "@ionic-native/health-kit": "^5.32.1",
    "@ionic-native/in-app-browser": "^5.31.1",
    "@ionic-native/keyboard": "^5.31.1",
    "@ionic-native/launch-review": "^5.36.0",
    "@ionic-native/local-notifications": "^5.30.0",
    "@ionic-native/native-page-transitions": "^5.36.0",
    "@ionic-native/open-native-settings": "^5.36.0",
    "@ionic-native/pdf-generator": "^5.36.0",
    "@ionic-native/photo-viewer": "^5.36.0",
    "@ionic-native/sign-in-with-apple": "^5.36.0",
    "@ionic-native/splash-screen": "^5.0.0",
    "@ionic-native/status-bar": "^5.0.0",
    "@ionic-native/streaming-media": "^5.32.1",
    "@ionic-native/taptic-engine": "^5.35.0",
    "@ionic-native/touch-id": "^5.36.0",
    "@ionic/angular": "^6.1.10",
    "@ionic/angular-server": "^6.1.10",
    "@ionic/cordova-builders": "^6.1.0",
    "@ionic/storage": "^2.3.1",
    "chart.js": "^3.7.0",
    "chartjs-adapter-date-fns": "^2.0.0",
    "cordova-ios": "6.2.0",
    "date-fns": "^2.28.0",
    "firebase": "^9.14.0",
    "firebase-admin": "^10.0.1",
    "firebase-functions": "^3.16.0",
    "moment": "^2.29.1",
    "rxjs": "~6.6.0",
    "smoothscroll-polyfill": "^0.4.4",
    "swiper": "^8.2.6",
    "tslib": "^2.2.0",
    "web-animations-js": "^2.3.2",
    "zone.js": "~0.11.4"

2 Likes

I’m having the same exact issue. I also noticed when viewing in Safari dev tools that on the iPhone, the app name is the proper app name, while on iPad, the app name is “localhost”

1 Like

Hi @kyle & @wkaskie Any solutions for this issue? We are also facing the same issue.

No luck for me. I was able to trigger a new error code “Unsupported OS” by manually calling a sign in method with FireAuth, so I’m suspecting FireAuth or Firebase to be the source of the issue.

1 Like

@wkaskie @rohithr-zenda

Finally found the fix for me, just had to add <preference name="AppendUserAgent" value="ipad" /> to config.xml. Hopefully this can help anyone running in to the same issue.

3 Likes

With this, splash screen is coming. But still showing white screen after that.
Thanks for sharing, hoping that now we will be able to debug more.

Thanks Kyle, you’re my hero!