Ionic 4 from 4.1.x to 4.3.0 entirely broken on Win10


#1

Running Windows 10.1803 and Ionic - this has been a problem since I first installed 4.x

I run the following…

ionic start test blank --type=angular
√ Preparing directory .\test - done!

After the “Preparing directory” message, nothing happens at all. Ctrl+C will not kill it, must kill node from the task list

So, I do the following instead

mkdir test
ionic start test blank --type=angular
? .\test exists. Overwrite? Yes
√ Preparing directory .\test - done!
√ Downloading and extracting blank starter - done!

, so now the process runs fine. In other words, I need to create the project directory in order for Ionic to create my app. I don’t think this is the intended process, or?

Sadly, the good parts stop about there, just a short while later I get problems with Ionic not finding VCBuild.exe and msbuild.exe. It seems it is searching for those in the directory C:\Program Files (x86)\MSBuild. If you have Visual Studio installed, msbuild.exe is not there, but in (for VS 2017): C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\15.0\Bin. I seriously hope you are not demanding we have to install VIsual Studio 2008, which is ancient, in order to use Ionic.

If you guys have hardcoded build stuff that was released with .NET Framework 3.5 some four hundred and fifty internet years ago or so, that’s not a good thing. I’ve been browsing the Microsoft site to find a place to install the

Building solution configuration “Release|x64”.
MSBUILD : error MSB3411: Could not load the Visual C++ component “VCBuild.exe”. If the component is not installed, either 1) install the Microsoft Windows SDK for Windows Server 2008 and .NET Framework 3.5, or 2) install Microsoft Visual Studio 2008. [E:\Projects\Ionic\test\node_modules\node-sass\build\binding.sln]
Done Building Project “E:\Projects\Ionic\test\node_modules\node-sass\build\binding.sln” (default targets) – FAILED.
Build FAILED.

gyp ERR! stack Error: C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe failed with exit code: 1

Now, then, after the failures, I try ionic serve… and, possibly related to the build errors, I get

[ng] ERROR in ./src/global.scss (./node_modules/raw-loader!./node_modules/postcss-loader/lib??embedded!./node_modules/sass-loader/lib/loader.js??ref–15-3!./src/global.scss)
[ng] Module build failed (from ./node_modules/sass-loader/lib/loader.js):
[ng] Error: Cannot find module ‘node-sass’
[ng] at Function.Module._resolveFilename (internal/modules/cjs/loader.js:587:15)
[ng] at Function.Module._load (internal/modules/cjs/loader.js:513:25)
[ng] at Module.require (internal/modules/cjs/loader.js:643:17)
[ng] at require (internal/modules/cjs/helpers.js:22:18)
[ng] at Object.sassLoader (E:\Projects\Ionic\IDA\node_modules\sass-loader\lib\loader.js:46:72)


Serve does not work (Ionic 4)
#2

I got the same error [ng] ERROR in ./src/global.scss …
It says a little further down [ng] Error: Cannot find module ‘node-sass’

So I just did a “npm install node-sass” in the project’s root directory and that seemed to fix the problem.
Now I can issue “ionic serve” and it compiles successfully and my app launches.


#3

Worked for me. Thanks!