Ionic 4 devapp debugging

Is there any way to debug Ionic 4 with devapp?

Im developing an aplication that uses Beacons and BLE and i really need debugging and ionic serve -c doesnt show anything

from what i read its a feature missing do you guys now any way to debug?

As the DevApp comes from the AppStore, it can’t have debugging enabled.

Just build your app yourself with ionic cordova build ios|android - it’s not that hard or complicated.

just run this in cmd

ionic serve --devapp

with this you can access your app in devapp but make sure your project and your device running on same network else it won’t work

ionic serve --devapp
This doesn’t work anymore. I have the following error:

> ng run app:ionic-cordova-serve --host= --port=8100 --cordova-mock --consolelogs --consolelogs-port=53703
[ng] Unknown option: '--consolelogs'
[ng] Unknown option: '--consolelogs-port'

I tried to update ionic CLI, but same thing. Did anyone experience the same thing lately?


Add platform and run the command again.

What do you mean?
I have iOS and Android added already.

So you are using Mac?

I’m experiencing the same error after updating to ionic 5.0.1


Yes, I’m on a Mac. Using the terminal.

Run this command instead:

ng run app:ionic-cordova-serve --host=X.X.X.X --port=8100 --cordova-mock

Change X.X.X.X by your local IP address

I have the same error with:


   Ionic CLI                     : 5.1.0 
   Ionic Framework               : @ionic/angular 4.3.0
   @angular-devkit/build-angular : 0.13.8
   @angular-devkit/schematics    : 7.2.4
   @angular/cli                  : 7.3.8
   @ionic/angular-toolkit        : 1.4.1


   Cordova CLI       : 9.0.0 (cordova-lib@9.0.1)
   Cordova Platforms : android 8.0.0, ios 5.0.1
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 3.1.2, (and 11 other plugins)


   cordova-res : not installed
   native-run  : 0.2.2


   Android SDK Tools : 26.1.1 
   NodeJS            : v10.15.3
   npm               : 6.9.0
   OS                : Windows 10

Has anyone solved the problem?

Thank you


if anyone is struggling with this - one requirement is @ionic/angular-toolkit >= 1.5.0

I’ve solved using the version 1.5.1, because using @latest it installs the version 2.0.0 that generates another error.
So in the file package .json I have:

    "@ionic/angular-toolkit": "~1.5.1",

It worked for me. thank you!