IONIC 3: Execution failed for task ':app:processDebugResources'


#1

Execution failed for task ‘:app:processDebugResources’.

This error comes when execute “ionic cordova build android”. Searched for a long time but no luck. Anyone can help?

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:processDebugResources’.
    Failed to execute aapt
  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or –
    debug option to get more log output.
  • Get more help at https://help.gradle.org
    BUILD FAILED in 4m 18s
    (node:9516) [DEP0018] DeprecationWarning: Unhandled promise rejections are
    deprecated. In the future, promise rejections that are not handled will
    terminate the Node.js process with a non-zero exit code.`

#2

Did you find any solution to that error?
Even I am getting the exact same error after executing,
ionic cordova build android.


#3

I have the same issue. Any update on it?


#5

Hello,
guys

Did you get any solution?
I have same issue


#6

can u share the log o/p?


#7

Same problem here, wonder if anybody sorted out this.


#8

hi guys, this kind of problem occurs due to the mismatch version of plugins and the version of android platform that you have added so, if you using latest version of plugin. so try to use previous version of plugin and build it.i solved just i have changed the version of my plugin.


#9

Hi Sanjay,
can you please give us the version of the plugins and the version of android that worked for you! i’ve been stuck with the same error
thanks!


#10

May be you deployed your app on --release or --prod, change the version of the app on config.xml and try again … thes work for me. May be too can be your android sdk version or gradle


#11

Hi, what i mean to say whatever plugin you have installed excluding those plugins which automatic installed at the time of creating project, so that plugin version use older version and build it so easily you can sort this error. :face_with_raised_eyebrow: