CordovaLib:processDebugResources FAILED

When I want to build an application on ionic (a blank, test project), the command “ionic cordova build android” returns this error:

BUILD FAILED

Total time: 1 mins 13.795 secs Error: /home/usuario/testeo/platforms/android/gradlew: Command failed with exit code 1 Error output: /home/usuario/Android/Sdk/build-tools/28.0.2/aapt: /home/usuario/Android/Sdk/build-tools/28.0.2/aapt: no se puede ejecutar el fichero binario

FAILURE: Build failed with an exception.

What went wrong: Execution failed for task ‘:CordovaLib:processDebugResources’.

com.android.ide.common.process.ProcessException: Failed to execute aapt.


I tried to reinstall many times Android SDK. I also tried differents versions of Android tools/platforms (25, 28) but it did nothing.

I’ve been dealing with this issue for more than 2 days at work, so i would really aprecciate if someone could offer some help :slight_smile: .

My info:

>     IONIC --> 3.12.0
>     Gradle --> 4.3.1
>     JVM --> 1.8.0_181 (Oracle Corporation 25.181-b13)
>     OS --> Linux 4.17.14-202.fc28.i686 i386 FEDORA
>     ANGULAR --> 1.0.0
>     NODE --> 7.8.0
>     NPM --> 4.2.0
>     CORDOVA --> 7.0.1 ANDROID --> 6.2.3

What is your ionic info output? What you posted is nice, but doesn’t cover everything.

Ionic CLI?
There is a newer version available. Update.

Your Cordova tooling seems to be out of date, which might be causing all kinds of problems.
You can read about how to figure out the current Cordova versions and how to update CLI, platforms and plugins here: https://ionic.zone/cordova/update