Ionic 2 RC0 App won't load even in serve

Tested starter app , everything was working.

– > Added a new page
–> Included in modules declarations and entryComponents
–> Imported in app.component.ts and made it a rootPage
–> Now nothing works , and won’t load. Even livereload wont work.

Decided to revert back

–> removed everything that i added , including all imports.
–> Reverted rootPage back to TabsPage.

Now , even this does not work.

Check the console :-

App is dead. Help is appreciated.

Isn’t it supposed to be just localhost:8100? without ionic-lab at the back

thats not lab serve. its just simple browser serve./ionic-lab will serve for android,ios and windows too.

i.e ionic serve --lab

Thanks… i just knew that… well, mine working just fine… have you try another address? ionic address
Im not running it on my localhost

Tried. same result. It was working on this address before. Thanks tho.

You should see a .tmp folder in the root of your project. Try deleting that and re-run ionic serve or just ionic build browser. There’s probably either a template syntax error or a TypeScript compilation error that’s not being flagged up.

Tried . :confused: didn’t work

I think you do have a build error, it’s just not showing you what the error is. I’ve found ionic build browser after deleting .tmp usually shows the compilation error.

yes even i tried build browser as you said , but no success.

I reverted everything with Ctrl+Z on each file I edited. . Now , its just a pure starter.

Thanks @webprofusion you were right. I forgot to revert tsconfig edits. now it works.

Hey, I’m trying to understand the issue here so we can help others. Did you have custom edits in tsconfig and then moving to our stock one fixed them?

Thanks, appreciate the help and feedback.

1 Like

Yes , moving to stock helped.
I added

    "types": [

at wrong place.

I feel terrible :stuck_out_tongue: Everything is working. Thanks for concern :slight_smile:

1 Like