Inputs lose focus in iOS simulator


#1

I am having a very strange problem when testing in iOS simulator. If I restart my Mac and run ionic run ios -lc --target="..." it only works properly once. If I try a second time, or make changes and live reload, as soon as I click on any input, it loses focus after about half a second.

Restarting the simulator doesn’t help.
Resetting the content and settings doesn’t help.
Starting a different simulator (target) doesn’t help.
There are no node processes still running in the background after I quit.
The only thing that seems to help is restarting my Mac.

I have tried creating a new project and adding a page with inputs. Same thing happens.
I have reinstalled cordova and ionic.
I have updated node and npm.

This used to work fine, until I updated to ionic 2.2.1. Rolling back to 2.1.17 didn’t help though.

ionic info
Your system information:

Cordova CLI: 6.5.0 
Ionic Framework Version: 2.0.0-rc.5-201701232249
Ionic CLI Version: 2.2.1
Ionic App Lib Version: 2.2.0
Ionic App Scripts Version: 1.0.0
ios-deploy version: Not installed
ios-sim version: Not installed
OS: OS X El Capitan
Node Version: v6.9.4
Xcode version: Xcode 7.3.1 Build version 7D1014

I have tried with and without ios-sim and ios-deploy.

Any one else experiencing the same problem. Any suggestions?


#2

I’ve been having similar if not same problem. It doesn’t happen consistently. I’ve removed the platform ios and reinstalled it.

This is my setup:

Cordova CLI: 6.4.0
Ionic CLI Version: 2.1.18
Ionic App Lib Version: 2.1.9
ios-deploy version: 1.9.0
ios-sim version: 5.0.13
OS: OS X El Capitan
Node Version: v6.9.2
Xcode version: Xcode 8.2 Build version 8C38

I have found that toggling the keyboard seems to help with text fields (Cmd-K). But I haven’t found a solution for the checkboxes when focus is lost.


Cannot focus input on emulator ios
#3

Thanks. After struggling for a couple of hours I eventually figured out it
was the software keyboard (cmd k). Not sure why it worked first time after
rebooting and not after that. I may have accidently switched the keyboard
off once, but not 3 times. Anyway, it’s working now.


#4

Wow, I’ve been dealing with this for months - and this finally saved me. Thank you!


#5

I had been dealing with this issue as well. Thanks for your solution!


#6

Using the Cmd-K helped me !


#7

Helped me too thanks! although it does make me wonder if on a real phone this means bluetooth keyboards might trigger this in deployment?? anyone tried?