Input very fast in ionic


#1

i’m using ionic and i feel input very fast when click.so how to return to default,when i tap show keybroard.when i touch or swipe,drag not show keybroard,tks!


#2

I suspect your <input> tags aren’t wrapped in Ionic’s labels. So, when you scroll, the field gets focus.

You need to do this:

<div class="list">
  <label class="item item-input">
    <input type="text" placeholder="First Name">
  </label>
  <label class="item item-input">
    <input type="text" placeholder="Last Name">
  </label>
  <label class="item item-input">
    <textarea placeholder="Comments"></textarea>
  </label>
</div>

#3
    <div class="list list-inset">
        <label class="item item-input item-stacked-label">
            <span class="input-label">Họ tên</span>
            <input type="text" placeholder="John" ng-model="registerData.fullname">
        </label>
        <label class="item item-input item-stacked-label">
            <span class="input-label">Tên đăng nhập</span>
            <input type="text" placeholder="Joe"  ng-model="registerData.username">
        </label>
Đăng ký

but not working! i scrolling touch focus input very fast keybroarh! im want tap show keyboarh! help me


#4

I think you’re going to need to give us some more info:

  1. Ionic version
  2. Desktop or Device?
  3. Device Version
  4. Have you tried this with the nightlies? There are frequent bug fixes that may already have solved your problem.

Also, can you post a CodePen sample of your work?


#5
<div class="list">
  <label class="item item-input">
    <input type="text" placeholder="First Name">
  </label>
  <label class="item item-input">
    <input type="text" placeholder="Last Name">
  </label>
  <label class="item item-input">
    <textarea placeholder="Comments"></textarea>
  </label>
</div>

i’m using code with device (iphone 5) .when i scroll…input have focus…


#7

If you want people to help you, then you should answer their questions :wink:

As Calandee already asked: Have your tried the nightlies?


#8

Thanks everyone for the help, I communicate in English less.Calandee I never knew about nightly, you can gcho little documentation I can refer to me please? (i’m using ionic version 1.0 beta)


#9

You can download the nightly build from here. Just copy the files to your www/lib folder.


#10

tks @mquadrat @Calendee i’m have fixed the problem! im using nightlies,

and @mquadrat, Can you tell me why when I input under footer.khi me to click on the keyboard is pressed it up automatically without pushing up the input, hope you help me


#11

Glad the nightlies helped out.

I think you’re going to need to explain " footer.khi " a little better. What is that?

By the way, iOS and Android automatically move / shrink the scroll view when the keyboard comes up. You can’t easily avoid that. There are a few config settings that manage HOW it happens, but that input is GOING to move. Period.


#12


I have tried many ways like a post here but still not effective! Can you give one number solution to this problem is not? I use the iphone 5 and nightly v1.0.0


#13

See if these help:


#14

tks you! i love ionic