[INFO] Waiting for connectivity with react-scripts

See this error message, I work around it by running the npm script directly but I am running into this on my new projects

aaronksaunders@Aarons1ProM1Pro mobile % ionic info               
[WARN] Error loading @capacitor/android package.json: Error: Cannot find module '@capacitor/android/package'
       Require stack:
       - /opt/homebrew/lib/node_modules/@ionic/cli/lib/project/index.js
       - /opt/homebrew/lib/node_modules/@ionic/cli/lib/index.js
       - /opt/homebrew/lib/node_modules/@ionic/cli/index.js
       - /opt/homebrew/lib/node_modules/@ionic/cli/bin/ionic


   Ionic CLI       : 6.19.0 (/opt/homebrew/lib/node_modules/@ionic/cli)
   Ionic Framework : @ionic/react 6.0.13


   Capacitor CLI      : 3.4.3
   @capacitor/android : not installed
   @capacitor/core    : 3.4.3
   @capacitor/ios     : 3.4.3


   cordova-res : not installed globally
   native-run  : 1.5.0


   NodeJS : v17.2.0 (/opt/homebrew/Cellar/node/17.2.0/bin/node)
   npm    : 8.4.1
   OS     : macOS Monterey

aaronksaunders@Aarons1ProM1Pro mobile % 

I’m getting the same message / error when I run “ionic serve” on a Mac. My “ionic info” was nearly identical. The same command worked fine on Windows.

I was running node 17.9 when I had the problem. I used nvm to change node versions to LTS (16.14.2 right now), and that fixed the problem.

nvm info: How to Install NVM on Mac with Brew - Fedingo

1 Like

will give it a go, trying to remember the reason I upgraded my node version