Info.plist file not found with no modern build

Hey there,
Since xcode update 10.2.1 I have this problem when I tried to build my IOS app:
Info.plist file not found.

And I already use the --buildFlag="-UseModernBuildSystem=0" option that was working for xcode version 10.X before 10.2.

Is somebody met the same issue ?

Don’t work?

I saw this post but I need to run the build in command line so I need to set legacy build system when I’m running emulate command.

By the way I tried to locate shared Workspace settings but couldn’t find it on Xcode.

Solution: Add “-- --buildFlag=”-UseModernBuildSystem=0" to end of command. So,
ionic cordova run ios -l -- --buildFlag="-UseModernBuildSystem=0"

Alternatively, you can add a “build.json” file to root of project instead with following code below and cordova will pickup build flag from there:
{ "ios": { "debug": { "buildFlag": [ "-UseModernBuildSystem=0" ] }, "release": { "buildFlag": [ "-UseModernBuildSystem=0" ] } } }

Hum it’s working now with -- --buildFlag="-UseModernBuildSystem=0"
And I have an other problem with device emulator target, I’ll dig in the forum to see if somebody had the same issue or I’ll create a new post.

Thanks a lot for your help guys

1 Like