I screwed up my project with npm update


#1

Hey,
I am working on a project I totally screwed up today :frowning:
It’s an Ionic project connected to a meteor-server/database. I started more or less one year ago and was really close to the end now.
Today I had the great idea to do an npm update and I guess also an npm update -g.
And now I can’t get my project running again. The real problem is, that I have no idea how up-to-date my package.json-files are and so I don’t know which versions were installed before. But I think I was working on version 2.0.0.rc.2, as my package-file says so for ionic-angular. Unfortunately I can’t get this exact version for ionic from npm anymore.
So, I do not really have the knowledge to upgrade my whole project to the newest version, especially because my biggest problems is the configuration. I used one from the Meteor-Tutorial and was happy that everything was just working out.
Do you think it’s better for me to start-over with a new project and transfer my code to it and pray that most of it will work? Or do you think someone of you can have a look on it and fix it in … let’s say … one hour that it will run on the old version again? I am really helpless, I have no idea what I can do now. So I am really thankful for any kind of help.

If anyone of you is willing to help me I can share the git-repo with you.


#2

What’s your ionic info?


#3

Now it is
Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-rc.5
Ionic CLI Version: 2.0.0
Ionic App Lib Version: 2.0.0

But can’t say what it was before… I wasn’t on Ionic2 stable, but I can’t get back to the RCs, npm doesn’t offer them


#4

There’s probably more to that output. Node version, npm version, etc.


#5

My current versions are

/home/sos/.npm-global/lib
├── angular@1.5.8
├── cordova@6.4.0
├── ionic@2.0.0
├── jshint@2.9.4
├── npm@5.6.0
└── tsd@0.6.5

but they already changed often today as I tried to get it run again …


#6

“dependencies”: {
"@angular/common": “2.1.1”,
"@angular/compiler": “2.1.1”,
"@angular/compiler-cli": “2.1.1”,
"@angular/core": “2.1.1”,
"@angular/forms": “2.1.1”,
"@angular/http": “2.1.1”,
"@angular/platform-browser": “2.1.1”,
"@angular/platform-browser-dynamic": “2.1.1”,
"@angular/platform-server": “2.1.1”,
"@ionic/app-scripts": “0.0.38”,
"@ionic/cloud-angular": “^0.8.0”,
"@ionic/storage": “1.1.6”,
"@types/cropperjs": “0.0.23”,
"@types/leaflet": “^1.0.53”,
“accounts-base-client-side”: “^0.1.1”,
“accounts-password-client-side”: “^0.3.2”,
“angular2-meteor-accounts-ui”: “^1.0.0”,
“angular2-moment”: “^1.0.0-beta.6”,
“babel-runtime”: “^6.18.0”,
“cropperjs”: “^1.0.0-beta.1”,
“ionic-angular”: “^2.0.0-rc.2”,
“ionic-native”: “2.2.6”,
“ionicons”: “3.0.0”,
“leaflet”: “^1.0.3”,
“meteor-client-side”: “^1.3.4”,
“meteor-node-stubs”: “^0.2.4”,
“meteor-rxjs”: “^0.4.4”,
“meteor-typings”: “^1.3.1”,
“moment”: “^2.16.0”,
“rxjs”: “^5.0.0-beta.12”,
“zone.js”: “^0.6.21”
},
“devDependencies”: {
"@ionic/app-scripts": “^0.0.38”,
"@types/chai": “^3.4.34”,
“awesome-typescript-loader”: “^2.2.4”,
“typescript”: “2.0.8”,
“typescript-extends”: “^1.0.1”
},


#7

That super old Ionic CLI is probably not helping. I would advise you to upgrade to a current, modern version and see what ionic info returns then. Should work with the super older ionic-angular project.

Releasing something with a RC version would be a really bad idea anyway, so take it as an opportunity to update to something a bit more stable.


#8

I found an old backup of my project folder and was now able to copy the node_modules folders form there into my current project.
The ionic-app is now running again, but the meteor-sever can’t find the module linked via an alias.

I had this problem one year ago as well. The strange thing is now, that in the backup-folder meteor finds the file and in the current project folder not. I checked the versions and they are more or less the same. Can you tell me which packages are influencing the webpack configuration and can screw up aliases? Or where else I can look for differences?
Another option I consider now would be to copy my whole code into the backup folder :slight_smile:


Of course I should upgrade to newer versions, but this is an university project nobody will ever use. I am/was really close to the end (about 2 weeks), so I really want to avoid to upgrade and migrate everything now.


#9

Yeah, today it’s the other way around. The server is running, and also the app seemed to be running but it can’t connect to the server. An 2days-old version on my phone can connect to the server without problem So there is something with the ionic app. But at this point I really have no idea any more… The app doesn’t send any requests when I click the login button and the server doesn’t response with any error…


#10

Another update…
In the incognito-tab of chrome or in another browser it’s working now…
On the phone of my girlfriend it’s working aswell.

In my normal chrome-tab it’s not working and on my phone neither.
I tried to clear cache/localstorage for chrome and cleared data on the phone, without positive results.
Any idea where something can be stored that isn’t deleted with mentioned operations?
Thanks


#11

Ionic storage icm sqlite plugin

See docs