I cant able install ionic 2 through npm , i try serval times by uninstalling and install it


#1

npm WARN deprecated node-uuid@1.4.7: use uuid module instead
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated node-uuid@1.3.3: use uuid module instead


#2

None of those look fatal.


#3

i get something similar but everything appears to be working.


#4

These are just warnings, but dont block ionic from being installed or working.
Node devs can add warning to their packages in order to tell people to update.
So somewhere in the CLI’s list of deps, someone is using an older version of a module.