How to fix the dependency issue when build created?


#1

Friends,
I try to create a production build using command

ionic cordova run android --prod

then I got error as

Error: The Angular Compiler requires TypeScript >=2.7.2 and <2.8.0 but 2.3.4 was found instead.
    at checkVersion (/home/user/mgov-master/node_modules/@angular/compiler-cli/src/transformers/program.js:806:19)
    at new AngularCompilerProgram (/home/user/mgov-master/node_modules/@angular/compiler-cli/src/transformers/program.js:109:13)
    at Object.createProgram (/home/user/mgov-master/node_modules/@angular/compiler-cli/src/transformers/program.js:812:16)
    at Object.createProgram (/home/user/mgov-master/node_modules/@angular/compiler-cli/src/ngtools_api2.js:36:26)
    at /home/user/mgov-master/node_modules/@ionic/app-scripts/dist/aot/aot-compiler.js:210:40
    at step (/home/user/mgov-master/node_modules/@ionic/app-scripts/dist/aot/aot-compiler.js:32:23)
    at Object.next (/home/user/mgov-master/node_modules/@ionic/app-scripts/dist/aot/aot-compiler.js:13:53)
    at fulfilled (/home/user/mgov-master/node_modules/@ionic/app-scripts/dist/aot/aot-compiler.js:4:58)
    at <anonymous>

Please advise how its can fix . I tried with typescript version 2.3.4 and ^2.3.4, ^2.7.2 but on that time also issue …

Thanks
Anes