How do I upgrade to CLI v1.6.x?


#1

When I run ionic io init I get

  _             _
 (_)           (_)
  _  ___  _ __  _  ___
 | |/ _ \| '_ \| |/ __|
 | | (_) | | | | | (__
 |_|\___/|_| |_|_|\___|  CLI v1.5.0

Usage: ionic task args

=======================

io is not a valid task

This seems to be because I’m on CLI v1.5.0. From what I have read, running sudo npm install -g ionic should update the CLI. That command runs fine other than some warnings (below), but afterwards, it’s still v1.5.0. Thoughts?

npm WARN engine cordova-js@4.0.0: wanted: {"node":"~0.10.x"} (current: {"node":"0.12.2","npm":"2.11.1"})
npm WARN engine npm@1.3.4: wanted: {"node":">=0.6","npm":"1"} (current: {"node":"0.12.2","npm":"2.11.1"})
npm WARN engine xmlbuilder@2.2.1: wanted: {"node":"0.8.x || 0.10.x"} (current: {"node":"0.12.2","npm":"2.11.1"})
npm WARN installMany normalize-package-data was bundled with npm@1.3.4, but bundled package wasn't found in unpacked tree

#2

I think this was a PATH problem. I tried it in Terminal instead of iTerm and it worked fine.