Newest Update Brought Errors


#1

I just installed to the latest version of Ionic and it brought up some npm warnings that I’m not sure how to fix:

npm WARN engine cordova-js@3.8.0: wanted: {"node":"~0.10.x"} (current: {"node":"0.12.3","npm":"2.10.0"})
npm WARN engine npm@1.3.4: wanted: {"node":">=0.6","npm":"1"} (current: {"node":"0.12.3","npm":"2.10.0"})
npm WARN engine xmlbuilder@2.2.1: wanted: {"node":"0.8.x || 0.10.x"} (current: {"node":"0.12.3","npm":"2.10.0"})
npm WARN installMany normalize-package-data was bundled with npm@1.3.4, but bundled package wasn't found in unpacked tree

Now certain ionic command line tools aren’t working, like --livereload.

Does anyone know what could be going on?

EDIT: I was able to fix this issue by reverting back to node 0.10.36.


#2

Yes…it appears Ionic needs to update their packages and libraries to work with Node v12.2.


#3

I’m experiencing the same issue.

npm WARN engine cordova-js@3.9.0: wanted: {"node":"~0.10.x"} (current: {"node":"0.12.4","npm":"2.10.1"})
npm WARN engine npm@1.3.4: wanted: {"node":">=0.6","npm":"1"} (current: {"node":"0.12.4","npm":"2.10.1"})
npm WARN engine xmlbuilder@2.2.1: wanted: {"node":"0.8.x || 0.10.x"} (current: {"node":"0.12.4","npm":"2.10.1"})
npm WARN installMany normalize-package-data was bundled with npm@1.3.4, but bundled package wasn't found in unpacked tree
/usr/local/bin/cordova -> /usr/local/lib/node_modules/cordova/bin/cordova
cordova@5.0.0 /usr/local/lib/node_modules/cordova

OS X Yosemite (10.10.3)

I’ve cleaned npm cache as well.


#4

That’s because it’s not configured to work with node 0.12.4. You are going to have to uninstall node.js and then install version 0.10.36.

Found here:

http://blog.nodejs.org/2015/01/26/node-v0-10-36-stable/

This is the quick fix until they update their libraries.


#5

Roger that. Thanks for the response. I’ll give it a go.