Help! (Suspected) Update to System WebView is causing my app to be rendered useless - how to identify root cause and mitigate?

I have an Ionic app, built and maintained with the original Ionic v1 that I have in use with several clients.

Recently, two clients reported back to me, almost simultaneously, that the app was starting to severely misbehave to such an extent that it wasn’t usable anymore.

Weirdly enough, the issue seems to be somewhat device/OS specific as I’ve found out that the devices these two clients are using are the TUFF T500 and the Hammer Energy 18x9. Looking at the product images and their specs, I have a suspicion that they are the same device that has just been rebranded.

The issues they were both experiencing looks to basically be critical rendering errors. The interface glitches out entirely making the app entirely unusable. It does respond to user input and doesn’t look to crash entirely - it’s just not usable.

The devices are all running Android 8.1 and no updates look to be available. We tried the usual “uninstall the app and re-install it again” as well as the “turn it off and on again”. Nothing worked. Our customers have even tried doing a factory reset on some of the affected devices - they end up displaying the same visual error either immediately or a short time after. None of the devices are governed by corporate policies, MDM or any of that sort.

None of the two customers were experiencing the issue on other devices than the TUFF/Hammer devices nor have any other customers experienced this. We have quite a lot of users who are using both newer, identical, or newer versions of Android. Nobody else has reported this issue nor are we able to reproduce it on any of our test devices.

We’re currently at a complete loss as to what is actually causing this with the exception that we believe that the WebView is the culprit. One of the clients did a bit of research and found that following the guide in this video helps. However, just for a short while. It seems that the some kind of update is automatically installed on the devices when they are left alone over night, so this usually only works for a day or two before they have to repeat the process.

Have any of you experienced anything like this? Any tips to what might be the root cause or just an idea what is so special about these devices that they are the only ones experiencing this?

1 Like

Sounds like you might want to join @richardshergold over here.

2 Likes

Yes that sounds like our issue. Please star the issue I have raised with the Chromium team and maybe add a comment. Thanks @rapropos

I think you’re absolutely right. Thanks a lot!

Hi Richard, I’ve done so. Thank you for your work on this.

I’ll be tracking progress on the Chromium team’s issue tracker. Let me know if there’s anything we can do.

1 Like