HELP - issue updating v1 framework to v1.4.0 Germany

Desperate here. I was running into a framework bug/error (details below) on my older v1 project when I realized I may not be running the latest v1 framework. Diving in deeper I find the following:

ionic info results:

Ionic cli: 6.10.1
Ionic framework: ionic1 1.0.0

In the www/lib/ioinic/version.json file its showing version: 1.0.0, codename: uranium-unicorn

But in my bower.json file its showing: version: 1.3.4, codename: hong kong. Also, I notice I have a .bower.josn file and a bower.json file.

A. Why does version file not show the same as bower files?
B. Why is ionic info showing Ionic1 1.0.0 and not Ionic1 1.3.4 - is that a result of the version file being wrong? Or what…?
C. and last, how do I force my install to the latest version 1.4.0 codename germany?

I tried doing a `npm install -g ionic@1.4.0 - and about half way through the install it throws an error

npm ERR! code EEXIST
npm ERR! path C:\Program Files\nodejs\node_modules\ionic\bin\ionic
npm ERR! dest C:\Program Files\nodejs\ionic
npm ERR! EEXIST: file already exists, cmd shim 'C:\Program Files\nodejs\node_modules\ionic\bin\ionic' -> 'C:\Program Files\nodejs\ionic'
npm ERR! File exists: C:\Program Files\nodejs\ionic
npm ERR! Remove the existing file and try again, or run npm
npm ERR! with --force to overwrite files recklessly.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\RPO\AppData\Roaming\npm-cache\_logs\2020-09-14T15_47_08_426Z-debug.log

I renamed the following three files C:\program files\nodejs(ionic | ionic.cmd | ionic.ps1) by adding .bak to each and tried again and it worked. But now ionic info on my project is giving me the error:

C:\Users\RPO\dev\myApp> ionic info
    throw err;

Error: Cannot find module 'internal/util/types'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
    at Function.Module._load (internal/modules/cjs/loader.js:562:25)
    at Module.require (internal/modules/cjs/loader.js:692:17)
    at require (internal/modules/cjs/helpers.js:25:18)
    at evalmachine.<anonymous>:44:31
    at Object.<anonymous> (C:\Users\RPO\AppData\Roaming\nvm\v10.21.0\node_modules\ionic\node_modules\vinyl-fs\node_modules\graceful-fs\fs.js:11:1)
    at Module._compile (internal/modules/cjs/loader.js:778:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    at Module.load (internal/modules/cjs/loader.js:653:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)

To fix this, I then did:

npm uninstall -g @ionic/cli
npm clear cache --force
npm install -g @ionlc/cli@6.10.1

…and after all that, my bower files and version files remain unchanged - it should say 1.4.0 : germany

What am I doing wrong?

Side note: thinking I am already on 1.3.4 I am not certain upgrading to 1.4.0 is actually going to fix the bug I am running into which is: leaving a cached tab view to another page…and then returning to the original page - which is throwing a documented bug related scrollTo error. (bug: Cannot read property 'scrollTo' of null (on uncached views))