Google plus failed in cordova and xcode 15

I have ionic project with the following info


   ionic (Ionic CLI)             : 4.12.0
   Ionic Framework               : @ionic/angular 7.8.2
   @angular-devkit/build-angular : 17.3.2
   @angular-devkit/schematics    : 17.3.2
   @angular/cli                  : 17.3.2
   @ionic/angular-toolkit        : 9.0.0


   cordova (Cordova CLI) : 11.1.0
   Cordova Platforms     : browser 6.0.0, ios 6.3.0
   Cordova Plugins       : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 5.0.0, (and 25 other plugins)


   ios-sim : 8.0.2
   NodeJS  : v18.19.1 (/usr/local/bin/node)
   npm     : 10.2.4
   OS      : macOS Unknown
   Xcode   : Xcode 15.3 Build version 15E204a

Recently, I upgraded the Xcode version to the latest version and upgraded angular and Jnode.

I installed all my packages from the beginning but, when I installed google plus my project crashed with the following error


The following build commands failed:
	Ld /Users/ABC/newapp/platforms/ios/build/emulator/ normal (in target 'newapp' from project 'newapp')
(1 failure)
xcodebuild: Command failed with exit code 65

The command I run:

ionic cordova plugin add cordova-plugin-googleplus --variable REVERSED_CLIENT_ID=com.googleusercontent.apps.535xxxxxx-djn1xxxxxxxxx --variable


# DO NOT MODIFY -- auto-generated by Apache Cordova
source ''
platform :ios, '12.0'
target 'newapp' do
	project 'newapp.xcodeproj'
	pod 'GoogleSignIn', '~> 5.0.2'
	pod 'GoogleUtilities', '~> 6.7'

I have checked Xcode Workplace, many errors are showing. looks like the Google Plus package crashed my project.
The same things happened when installing Facebook4, Fcm, and Filetransver plugins.

Am I missing something?
Please help

did you install the awesome cordova wrapper for the plugin? Google Plus | Awesome Cordova Plugins.

That plugin you are using is outdated. Here’s an updated capacitor plugin you should be using instead: GitHub - CodetrixStudio/CapacitorGoogleAuth: Capacitor plugin for Google Auth. Lightweight & no dependencies.

Thank you for your reply
I’m using cordova, is it possible to use capacitor plugin inside cordova?

This issue also happened with many plugins not only with Google plus

Do you think it’s plugin issue or xcode issue?

Yes, I have installed awesome Cordova plugins but still the same issue.

This is one of the errors when installing Google Plus


Plugin issue. First off: there is no such thing as google+ anymore, the social service is dead. The plugin you are trying to use is outdated. you need to switch.


Thank you very much I’ll try that plugin.

What about cordova Filetransfer, Facebook4, and FCM? Are they still supported ?
All of these have the same issue

More than likely, yes. To be sure, you need to go to each repo and check. There is no master list of supported 3rd party plugins. I could imagine that would be hell to maintain.

I’m not able to use CapacitorGoogleAuth plugin in Cordova app
Is there any suggestion for another Cordova plugin for Google Sign-in that supports Xcode latest version?