Gajotres - load/add/remove contacts - assertion failed


#1

Hello all,

i think some of you had also used this tutorial for loading contacts:

Now, i had done every little step, but i doesn’t work well. I can add the contact, but that’s it. Loading or removing didn’t work. I just got this error message:

Jan 28 21:37:27 localhost assertiond[1938]: assertion failed: 15C50 13B137: assertiond + 12188 [93FFE0B6-5C27-387F-B32A-6EE378BBB22A]: 0x1

Does anybody know, what this means? Or where can i look, to find out, what this message means?


#2

You know my blog is still active :slight_smile: you can always leave a comment, and I’ll answer it. I will always find time for my readers.

To make your life easier, I’ve created a GitHub repo for that example. Download it and deploy according to attached instructions

I’ve retested it myself today so I can vouch it works. Though I tested it only on Android platform.

Last but not least, what platform is causing you this problem?


#3

I had tested it on Mac OS X (El Capitan).

Next time, i will use your blog :smile:

But this time … i got problems starting android … had never build it before.


ERROR: Error: Failed to find ‘ANDROID_HOME’ environment variable. Try setting setting it manually.
Failed to find ‘android’ command in your ‘PATH’. Try update your ‘PATH’ to include path to valid SDK directory.

I now install Android SDK and JDK. Is there something more to do?


#4

While I own Mac, I don’t have any experience with it (it’s stored in my closet).

Technically, you will ned to and an ANDROID_HOME and JAVA_HOME environment variable. You will also need to include these locations to PATH.

This will probably help you: http://www.cyberciti.biz/faq/appleosx-bash-unix-change-set-path-environment-variable/


#5

And how do you develop iOS apps without Mac? Than you take the Mac out of the closet? :slightly_smiling:

Have you tested your example on iOS emulator? I think it doesn’t load all contacts.


#6

Usually, I ask my colleague to do that, though I can’t remember what happened in this case. I will ask him to retest it again.

On the other hand, if this plugin is not retrieving all contact data you should open a ticket at the official plugin repo.


#7

Update:
Get the android simulator started.
But now i got the error:
“Unfortunately, IonicContactsDemo has stopped” …
Does anyone with a mac get the example started?

I still got this error by clicking at load:
Feb 20 00:08:27 localhost IonicContactsDemo[1123]: Dohvati
Feb 20 00:08:30 localhost assertiond[1074]: assertion failed: 15C50 13B137: assertiond + 12188 [93FFE0B6-5C27-387F-B32A-6EE378BBB22A]: 0x1


#8

I am getting this same error. I am working on a mac. I am emulating ios.
I am not running your same example. My lists are added updating and working just fine.

But I want to know why the error is showing up.


#9

So it loads your contacts, but also logs the assertion error?

I solved my problem. Now, it also loads my contacts, but always returning the assertion failure. No idea why this happens.