Firebase.h file not found

Ionic 3 app with cordova-plugin-firebasex works fine in Android, but in iOS gives the error when doing a build
'Firebase.h' file not found
referring to FirebasePlugin.m.
Any idea how to resolve this? I’ve tried removing and re-adding the plugin, and also re-adding the iOS platform, but no luck!


1 Like

Same issue…The error is gone after I did changes from

but I am now facing a different issue where is fails with following error

The following build commands failed:
CompileC /Users/ionic/Library/Developer/Xcode/DerivedData/RisingBee-bjesvdiqduwsvqgfbjemswfvtnep/Build/Intermediates.noindex/ArchiveIntermediates/RisingBee/IntermediateBuildFilesPath/ /Users/ionic/builds/project-0/platforms/ios/RisingBee/Plugins/cordova-plugin-firebasex/FirebasePlugin.m normal armv7 objective-c
(1 failure)
[04:43:29]: Exit status: 65

Now again getting the firebase.h issue.

It went away after removing both iOS and Android platforms and reinstalling. Try it and see if it works. Good luck.

1 Like

make sure you have the following :

  1. cordova version>=9
  2. ios version >=5

And run the following commands in terminal

sudo gem install cocoapods-dependencies

cd platforms/ios/
pod dependencies

ionic cordova build ios

And then open the following path in Xcode:

platforms ->ios YourProject.xcworkspace(notYourProject.xcodeproj` )

And run the app from xCode

check the below url for reference:

1 Like

Thanks, I tried that but the error was still there.

I came across this solution that worked

But now I’m getting Module ‘FirebaseInstanceID’ not found error. Any ideas?

1 Like

i am getting the same error. got any solutions?

Did you try @cvidhya’s solution? Try it after removing and readding iOS platform.

The issue is with the coco pod version. Try to uninstall and reinstall the cocopod correctly.