Failed to install 'cordova-plugin-firebase' in iOS

Failed to install ‘cordova-plugin-firebase’: CordovaError: Using “requireCordovaModule” to load non-cordova module “xcode” is not supported. Instead, add this module to your dependencies and use regular “require” to load it.
Node -V:8.12.0
NPM:6.4.1
Ionic 5.2.4