Error with Git creating blank project


#1

Hi

I have created a new blank project with the last version 3.13.1. At the end of the creation I get this error:

[ERROR] An error occurred while running git rev-list --count HEAD (exit code

    128):

    fatal: ambiguous argument 'HEAD': unknown revision or path not in the
    working tree.
    Use '--' to separate paths from revisions, like this:
    'git <command> [<revision>...] -- [<file>...]

I have reinstalled the Git to version 2.14.2 and the try again this time with the new command ionic doctor check and get the same error.

Some Idea?

Thanks!!!


#2

What is your ionic info output?
What exact command are you running?


#3

Hi

Thanks for the quick answer

I get the same error creating the project with:

ionic start projectName

and just after, checking with:

ionic doctor check

$ ionic info

cli packages: (C:\Users\ASUS\AppData\Roaming\npm\node_modules)

    @ionic/cli-utils  : 1.13.1
    ionic (Ionic CLI) : 3.13.1

local packages:

    @ionic/app-scripts : 3.0.0
    Ionic Framework    : ionic-angular 3.7.1

System:

    Node : v6.11.3
    npm  : 3.10.10
    OS   : Windows 7

Misc:

    backend : pro

Thanks


#4

Nice tool! Could someone please point me to this documentation? I’m looking for the list of valid arguments.


#5

There doesn’t seem to be any docs but this:


#6

The output you posted only shows ionic info, which unfortunately doesn’t help.

Where is the folder located where you are running the commands?
Run npm list --depth=0 in it.
Run npm list -g --depth=0 as well.


#7

Hi

In the code bellow you can see from where I executed the ionic info (from inside a project).
Here are the result of the commands:

ASUS@ASUS-PC MINGW64 /d/004_MAKER/WS/4i (master)
$ npm list --depth=0
4i@0.0.1 D:\004_MAKER\WS\4i
+-- @angular/common@4.4.3
+-- @angular/compiler@4.4.3
+-- @angular/compiler-cli@4.4.3
+-- @angular/core@4.4.3
+-- @angular/forms@4.4.3
+-- @angular/http@4.4.3
+-- @angular/platform-browser@4.4.3
+-- @angular/platform-browser-dynamic@4.4.3
+-- @ionic-native/core@4.3.0
+-- @ionic-native/splash-screen@4.3.0
+-- @ionic-native/status-bar@4.3.0
+-- @ionic/app-scripts@3.0.0
+-- @ionic/storage@2.0.1
+-- ionic-angular@3.7.1
+-- ionicons@3.0.0
+-- rxjs@5.4.3
+-- sw-toolbox@3.6.0
+-- typescript@2.3.4
`-- zone.js@0.8.18

And

ASUS@ASUS-PC MINGW64 /d/004_MAKER/WS/4i (master)
$ npm list -g --depth=0
C:\Users\ASUS\AppData\Roaming\npm
+-- @angular/cli@1.4.4
+-- bower@1.8.0
+-- cordova@7.1.0
+-- generator-angular-fullstack@5.0.0-beta.0
+--  error: ENOENT: no such file or directory, open 'C:\Users\ASUS\AppData\Roami
ng\npm\node_modules\generators_explained.rtf\package.json
+-- gulp-cli@1.4.0
+-- ionic@3.13.1
+-- raml2html@6.4.1
+-- rxjs@5.0.3
+-- typescript@2.5.3
+-- webpack@3.0.0
+-- windows-build-tools@1.3.2
`-- yo@2.0.0

npm ERR! error in C:\Users\ASUS\AppData\Roaming\npm\node_modules\generators_expl
ained.rtf: ENOENT: no such file or directory, open 'C:\Users\ASUS\AppData\Roamin
g\npm\node_modules\generators_explained.rtf\package.json'

Thanks


#8

No idea, I can only suggest to create an issue at https://github.com/ionic-team/ionic-cli/issues


#9

I will thank you for trying !!!