Error when doing ionic run android or emulate


#1

I get this message whenever i try to do ionic run android or ionic emulate android =/ tried reinstalling ionic but the same thing is happening. Using a blank template to run. It runs on ripple emulator though and I’ve tried searching for fixes to this which I can’t find =/

D:\Programming\Ionic\Wakker Ionic\Wakker\platforms\android\cordova\node_modules\q\q.js:126
throw e;
^

Error: Device communication timed out. Try unplugging & replugging the device.
at null._onTimeout (D:\Programming\Ionic\Wakker Ionic\Wakker\platforms\android\cordova\node_modules\q\q.js:1717:25)
at Timer.listOnTimeout (timers.js:89:15)
Error: cmd: Command failed with exit code 1
at ChildProcess.whenDone (C:\Users\euphonious\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:139:23)
at emitTwo (events.js:87:13)
at ChildProcess.emit (events.js:172:7)
at maybeClose (internal/child_process.js:817:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)

ionic info:

Your system information:

Cordova CLI: 5.3.1
Ionic Version: 1.1.0
Ionic CLI Version: 1.6.4
Ionic App Lib Version: 0.3.8
OS: null
Node Version: v4.0.0


#2

Hi,

I am also getting the same error.
Till last night ‘ionic run android’ command was working fine and today morning when i compile, i am getting the same above mentioned error.
Please help me. I am stuck with my development.

Regards,
Raj