Error: plugins not supported

I am having this error come up when working with plugins for Android builds. iOS is working fine and all the plugins work for that.
However, after doing the following:

ionic cordova platform rm android
ionic cordova platform add android@6.3.0
ionic cordova prepare android
ionic cordova build android

(I’m using 6.3.0 after reading a number of posts about the problems I’m having)

After step two is the first sign of trouble:

Failed to install 'cordova-plugin-fingerprint-aio': CordovaError: Uh oh!
"<path-to>app/platforms/android/res/drawable/ic_fingerprint_error.xml" already exists!
Error: Uh oh!
"<path-to>app/platforms/android/res/drawable/ic_fingerprint_error.xml" already exists!

Pushing ahead and trying out the build (it wont build if its not using 6.3.0) there are four plugins now that don’t work and give error messages using remote Debugging on a Google Pixel:

vendor.js:20011 Native: tried calling Splashscreen.hide, but the Splashscreen plugin is not installed.
pluginWarn @ vendor.js:20011
vendor.js:20016 Install the Splashscreen plugin: 'ionic plugin add cordova-plugin-splashscreen'
pluginWarn @ vendor.js:20016

The same thing shows up for these three:

In the past, doing something like this:

$ ionic cordova plugin rm cordova-plugin-splashscreen
$ ionic cordova plugin add cordova-plugin-splashscreen

Has worked to fix the issue for all but the in-app browser.
However, with the steps listed above, I get the following when removing this plugin:

$ ionic cordova plugin add cordova-plugin-splashscreen
Uninstalling cordova-plugin-splashscreen from android
Uninstalling cordova-plugin-splashscreen from browser
Uninstalling cordova-plugin-splashscreen from ios
Error: plugins not supported.
[ERROR] An error occurred while running cordova plugin remove cordova-plugin-splashscreen --save (exit code 1).

The cordova-plugin-splashscreen directory is still in the plugins directory after this.

Any ideas on what the issue is?

BTW, here is my

$ ionic info
cli packages: (/usr/local/lib/node_modules)
  @ionic/cli-utils : 1.19.1
  ionic (Ionic CLI) : 3.19.1
global packages:
  cordova (Cordova CLI) : 7.0.1
local packages:
  @ionic/app-scripts : 3.0.1
  Cordova Platforms : android 6.2.3 browser 4.1.0 ios 4.5.4 plugins
  Ionic Framework : ionic-angular 3.8.0
  ios-deploy : 1.9.2
  ios-sim : 5.0.4
  Node : v8.9.4
  npm : 5.6.0
  OS : macOS High Sierra
  Xcode : Xcode 9.2 Build version 9C40b
Environment Variables:
  ANDROID_HOME : not set
  backend : pro

Any help is much appreciated!

1 Like