Error on graceful-fs when using ionic platform command

Hello guys i am trying to remove the iOS platform from my project in order to install the Android platform. But when i run the command ionic platform remove ios this error occurs:

(node:2191) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

My os is OSX el capitan
node version v6.9.1
graceful-fs v4.1.11
ionic 2.1.8 ionic

when i am trying to run npm install graceful-fs

i get this error :

westattica@1.1.1 /Users/vk/Desktop/2/WestAttica
├── UNMET PEER DEPENDENCY @angular/core@^2.1.1 || ^4.0.0
└── graceful-fs@4.1.11

npm WARN @ionic/cloud-angular@0.12.0 requires a peer of @angular/core@^2.1.1 || ^4.0.0 but none was installed.
npm WARN westattica@1.1.1 No repository field.
npm WARN westattica@1.1.1 No license field.

i have seen some posts with this error but noone of the solutions seems to work.

any ideas?
thanks in advance

This isn’t an error. It might be a problem, but npm throws warnings like this all the time when you install from Github. Does your project build and run?

yes it runs and builds smoothly and run in the emulator too.

The peer dependency fail on @angular/core looks serious to me.

This is not necessary. You can have both at the same time.

Ionic or Ionic CLI? Post your ionic info output.

Also post the package.json of your project, something is fishy.

hello @Sujan12 and sorry for being late,

here is the results from ionic info command:

Cordova CLI: 4.2.0
Ionic CLI Version: 2.1.8
Ionic App Lib Version: 2.1.4
ios-deploy version: 1.9.0
ios-sim version: 5.0.11
OS: OS X El Capitan
Node Version: v6.9.1
Xcode version: Xcode 8.2.1 Build version 8C1002

and here is my package.json file :

“name”: “westattica”,
“version”: “1.1.1”,
“description”: “WestAttica: An Ionic project”,
“dependencies”: {
"@ionic/cloud": “^0.16.0”,
"@ionic/cloud-angular": “^0.12.0”,
“gulp”: “^3.5.6”,
“gulp-concat”: “^2.2.0”,
“gulp-minify-css”: “^0.3.0”,
“gulp-rename”: “^1.2.0”,
“gulp-sass”: “^2.0.4”
“devDependencies”: {
“bower”: “^1.3.3”,
“gulp-util”: “^2.2.14”,
“shelljs”: “^0.3.0”
“cordovaPlugins”: [
“cordovaPlatforms”: [ ]

Why do you have bower and gulp dependencies? Why don’t you have any angular or ionic ones? How was this project spawned?

I had started the project in ubuntu where, i had installed bower and gulp, in ionic v1 ( i think with v1.3) with android platform. then i copied it to osx ( without the android platform ), but the ionic version that was installed on the osx was ionic 2.1.8. Although when i tried to add ios package everything was ok. Now i was able to add the android platform but the message for graceful-fs remains and shown in every command i run for ionic projects and cordova plugins. Also the error with the angular core remains. About the angular and ionic dependencies, i dont know why they aren’t exist :confused:

That isn’t going to work. You can’t migrate a v1 project to current version. You are going to have to start from scratch with a new project.

As this is only Ionic CLI, you can continue developing with Ionic v1. But actually you should upgrade that CLI to the current version as fast as possible.

I edited the post category to reflect that you are working on a v1 project.

You can’t use the cloud-angular libary, look at the “Ionic v1” version of the Services docs.

1 Like

thanks for your help guys,
i will update my CLI version and i will make my project from scratch in ionic v1.
Thanks again for your time and your help!