Error occurred while loading plugins. CLI functionality may be limited

Thanks for the link!!!

Thank you so much, It works for me :slight_smile:

Thanks you work for me roll back to v2.2.3

1 Like

After installing cli 3.0 I had the same error.
I added in package.json in “devDependencies” code:
"@ionic/app-scripts": “1.3.7”,
"@ionic/cli-plugin-cordova": “1.0.0”,
"@ionic/cli-plugin-ionic-angular": “1.0.0”,
“typescript”: "2.2.1"
Next npm install and went

Hey, if you have this error please don’t just fix it by running some random code from here but tr this and post the output here:

Maybe we will be able to debug the problem then and fix it in the next version so nobody else has to go through these step at all. Thanks you

I just installed latest version of Ionic, and when I run ionic -v I get the following errors:

ionic -v --verbose
[ERROR] Error occurred while loading plugins. CLI functionality may be limited.
        Checking for CLI updates now...
[ERROR] No updates found after plugin error--please report this issue.
3.0.0

Someone having a solution that’s not downgrading ionic?

Do you already have a local Ionic project?
If not: What happens if you run ionic start --verbose?
If yes: What happens if you run ionic info in its folder?

I encountered a similar error but I can’t say it’s exactly the same.
I’m glad if this is helpful.

$ ionic info --verbose
[ERROR] Error occurred while loading plugins. CLI functionality may be limited.
        Checking for CLI updates now...
[DEBUG] Plugin error: FILE_INVALID_JSON
[DEBUG] Checking for latest plugin version of ionic@latest.
"3.0.0"

[DEBUG] Latest version of ionic@latest is .
[DEBUG] !!! ERROR ENCOUNTERED !!!
SyntaxError: Unexpected end of JSON input
[DEBUG] SyntaxError: Unexpected end of JSON input
            at JSON.parse (<anonymous>)
            at /usr/local/lib/node_modules/ionic/node_modules/@ionic/cli-utils/dist/lib/plugins.js:212:36
            at Generator.next (<anonymous>)
            at fulfilled (/usr/local/lib/node_modules/ionic/node_modules/@ionic/cli-utils/dist/lib/plugins.js:4:58)

I solved this by myself.
It seems to be caused by broken ‘ionic.config.json’.

Fixed this json, that problem no more occurs.
I don’t remember that an automatic modification by ionic caused this or I accidently modifed this file.

Sorry for confusing, if this is completely different issue.
Thanks

install each package unmet peer dependency
npm install --save @angular/xxxx

or

delete node_modules folder update package.json as seen on https://github.com/driftyco/ionic/releases
and then install new requirement package with npm install

Thanks, worked for me too :smile:

it works for me thanks @lsantaniello

5 posts were split to a new topic: [ERROR] Error occurred while loading plugins. CLI functionality may be limited

thank you very much, worked for me

$ npm install -g cordova
$ npm install --save-dev --save-exact @ionic/cli-plugin-cordova@latest

Install both.It resolved my issue.

@davidnakoko You save my life. Thank you.

worked for me. Thank you

“… where all bugs are fixed.”

SMH. if only …

Well, in the context of CLI 2.x this is the most fixed version :stuck_out_tongue: