Error message

Hi there,

I got this build output error message twice trying to build package

ANDROID_HOME=/opt/android-sdk
JAVA_HOME=/usr/lib/jvm/java-8-oracle
Error: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.
Looked here: /opt/android-sdk/tools/templates/gradle/wrapper

What can i do to enable me solve this problem?

Post your ionic info output please.
What is the exact command you are running?
What does cordova requirements output?

1 Like

C:\FoodWikiNG\FoodWikiNg>ionic info

cli packages:

@ionic/cli-plugin-ionic-angular : 1.4.0 (C:\FoodWikiNG\FoodWikiNg\node_modules\@ionic\cli-plugin-ionic-angular)
@ionic/cli-utils                : 1.6.0 (C:\FoodWikiNG\FoodWikiNg\node_modules\@ionic\cli-utils)
ionic (Ionic CLI)               : 3.6.0 (C:\FoodWikiNG\FoodWikiNg\node_modules\ionic)

local packages:

@ionic/app-scripts : 2.1.3
Ionic Framework    : ionic-angular 3.6.0

System:

Node : v6.11.1
OS   : Windows 10
npm  : 3.10.10

Why do you post in the ionic-v1 category?

Sorry about that… How do i go about it now?

(I changed the category for you)

Start by answering the other 2 of the 3 questions I asked.

C:\FoodWikiNG\FoodWikiNg>ionic info

cli packages:

@ionic/cli-plugin-ionic-angular : 1.4.0 (C:\FoodWikiNG\FoodWikiNg\node_modules\@ionic\cli-plugin-ionic-angular)
@ionic/cli-utils                : 1.6.0 (C:\FoodWikiNG\FoodWikiNg\node_modules\@ionic\cli-utils)
ionic (Ionic CLI)               : 3.6.0 (C:\FoodWikiNG\FoodWikiNg\node_modules\ionic)

local packages:

@ionic/app-scripts : 2.1.3
Ionic Framework    : ionic-angular 3.6.0

System:

Node : v6.11.1
OS   : Windows 10
npm  : 3.10.10