Error from first install


#1

Hello, when i type the “sudo npm install -g cordova ionic” command in my terminal (Mac OS) I get the message :

npm WARN engine cordova-js@3.8.0: wanted: {“node”:"~0.10.x"} (current: {“node”:“0.12.2”,“npm”:“2.7.4”})
npm WARN engine npm@1.3.4: wanted: {“node”:">=0.6",“npm”:“1”} (current: {“node”:“0.12.2”,“npm”:“2.7.4”})
npm WARN engine xmlbuilder@2.2.1: wanted: {“node”:“0.8.x || 0.10.x”} (current: {“node”:“0.12.2”,“npm”:“2.7.4”})
npm WARN installMany normalize-package-data was bundled with npm@1.3.4, but bundled package wasn’t found in unpacked tree

What should I do to correct it ?

Thanks,
Jean-Charles


#2

Your node and npm seems to be not up to date. Have you tried to update them?


#3

Thanks for your reply. Actually I downgraded from node 0.12.2 to node 0.10.38 and now it works. Read on some forums that cordova can have some trouble with the latest version of node


#4

I had the same issue on Windows7. Downgrading nodejs to 0.10.38 version helped.